aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/lxdm
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-06-07 15:27:01 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-06-20 12:28:00 +0200
commitd56cac1bf1ae77479d7bb5803c948ffd9da12e44 (patch)
tree72b32291b91fa87f26e56b461803cc9edf6d5765 /meta-oe/recipes-graphics/lxdm
parent010f75a8d052251fee1bb2d42f926693fade962c (diff)
downloadmeta-openembedded-contrib-d56cac1bf1ae77479d7bb5803c948ffd9da12e44.tar.gz
lxdm: remove consolekit dependencies in systemd environment and fix build
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/lxdm')
-rw-r--r--meta-oe/recipes-graphics/lxdm/lxdm/0002-configure-check-only-for-ck-connector-in-case-consol.patch48
-rw-r--r--meta-oe/recipes-graphics/lxdm/lxdm_git.bb6
2 files changed, 52 insertions, 2 deletions
diff --git a/meta-oe/recipes-graphics/lxdm/lxdm/0002-configure-check-only-for-ck-connector-in-case-consol.patch b/meta-oe/recipes-graphics/lxdm/lxdm/0002-configure-check-only-for-ck-connector-in-case-consol.patch
new file mode 100644
index 0000000000..e2ba52a8c8
--- /dev/null
+++ b/meta-oe/recipes-graphics/lxdm/lxdm/0002-configure-check-only-for-ck-connector-in-case-consol.patch
@@ -0,0 +1,48 @@
+From 8657bfcfc5c26382989001e9b6d18295d740c709 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
+Date: Fri, 7 Jun 2013 14:13:41 +0200
+Subject: [PATCH] configure: check only for ck-connector in case consolekit is
+ enabled
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+it failed for --disable-consolekit with
+
+| lxdm.c:70:26: fatal error: ck-connector.h: No such file or directory
+| compilation terminated.
+| make[2]: *** [lxdm_binary-lxdm.o] Error 1
+
+Upstream-Status: submitted [1]
+
+[1] http://sourceforge.net/mailarchive/message.php?msg_id=31010893
+
+Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
+---
+ configure.ac | 3 +--
+ 1 files changed, 1 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 9e21a22..49ba944 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -28,8 +28,6 @@ if test "x$USE_PAM" != "xno" ; then
+ fi])
+ fi
+
+-AC_CHECK_LIB([ck-connector],[ck_connector_open_session])
+-
+ # Checks for header files.
+ AC_PATH_X
+ AC_CHECK_HEADERS([shadow.h stdlib.h string.h unistd.h utmpx.h])
+@@ -102,6 +100,7 @@ if test "x$enable_consolekit" = "xyes" ; then
+ AC_SUBST(CONSOLEKIT_LIBS)],[
+ echo "ConsoleKit devel package not found"
+ ])
++ AC_CHECK_LIB([ck-connector],[ck_connector_open_session])
+ fi
+
+
+--
+1.7.6.5
+
diff --git a/meta-oe/recipes-graphics/lxdm/lxdm_git.bb b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
index 6675691e60..8767e98fc7 100644
--- a/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
+++ b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
@@ -8,6 +8,7 @@ SRC_URI = " \
file://lxdm-pam \
file://lxdm-pam-debug \
${@base_contains("DISTRO_TYPE", "debug", "", "file://0001-lxdm.conf.in-blacklist-root-for-release-images.patch",d)} \
+ file://0002-configure-check-only-for-ck-connector-in-case-consol.patch \
"
LXDM_PAM = "${@base_contains("DISTRO_TYPE", "debug", "lxdm-pam-debug", "lxdm-pam",d)}"
@@ -17,7 +18,8 @@ PV = "0.4.2+git${SRCPV}"
PE = "1"
PR = "r7"
-DEPENDS = "cairo consolekit dbus gdk-pixbuf glib-2.0 gtk+ virtual/libx11 libxcb pango"
+DEPENDS = "cairo dbus gdk-pixbuf glib-2.0 gtk+ virtual/libx11 libxcb pango"
+DEPENDS += "${@base_contains("DISTRO_FEATURES", "systemd", "", "consolekit", d)}"
# combine oe-core way with angstrom DISTRO_TYPE
DISTRO_TYPE ?= "${@base_contains("IMAGE_FEATURES", "debug-tweaks", "debug", "",d)}"
@@ -26,7 +28,7 @@ inherit autotools gettext systemd
S = "${WORKDIR}/git"
-EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}"
+EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/ --disable-consolekit', '--without-systemdsystemunitdir', d)}"
do_compile_append() {
# default background configured not available / no password field available / no default screensaver