aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/lxdm
diff options
context:
space:
mode:
authorstephen.arnold42 <stephen.arnold42@gmail.com>2014-03-18 02:09:08 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-03-23 21:53:58 +0100
commit7dfa6be8c5d9b093ae79c403c685c6b8ed6216dd (patch)
tree881a613b4a27a255714f4f3a44b4aad00e74f7f6 /meta-oe/recipes-graphics/lxdm
parentb306212c8919a8638d5e97acfd6262bcbd3401ed (diff)
downloadmeta-openembedded-contrib-7dfa6be8c5d9b093ae79c403c685c6b8ed6216dd.tar.gz
recipes-graphics/lxdm: autotools and config updates
lxdm_git.bb: Upstream changes required autotools and gettext (intl) updates; the package autogen script doesn't create the makefile in po, but autotools by itself is missing the input file (thus, the configure_prepend). There were also missing depends (from upstream docs and configure checks) and some configure options were added to ensure the desired X/gtk2 config and enable (optional) auto-login. Signed-off-by: Stephen Arnold <stephen.arnold42@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/lxdm')
-rw-r--r--meta-oe/recipes-graphics/lxdm/lxdm_git.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/meta-oe/recipes-graphics/lxdm/lxdm_git.bb b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
index c12eddf23a..c602ad3816 100644
--- a/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
+++ b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
@@ -16,17 +16,24 @@ SRCREV = "07fb151a99ef99318b71f3de0afbba977b1e6267"
PV = "0.5.0+git${SRCPV}"
PE = "1"
-DEPENDS = "cairo dbus gdk-pixbuf glib-2.0 gtk+ virtual/libx11 libxcb pango"
+DEPENDS = "virtual/libintl intltool-native cairo dbus gdk-pixbuf glib-2.0 gtk+ virtual/libx11 libxcb pango iso-codes"
DEPENDS += "${@base_contains("DISTRO_FEATURES", "systemd", "", "consolekit", d)}"
# combine oe-core way with angstrom DISTRO_TYPE
DISTRO_TYPE ?= "${@base_contains("IMAGE_FEATURES", "debug-tweaks", "debug", "",d)}"
-inherit autotools gettext systemd
+inherit autotools pkgconfig gettext systemd
S = "${WORKDIR}/git"
-EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/ --disable-consolekit', '--without-systemdsystemunitdir', d)}"
+CFLAGS_append = " -fno-builtin-fork -fno-builtin-memset -fno-builtin-strstr "
+
+EXTRA_OECONF += "--enable-gtk3=no --enable-password=yes --with-x -with-xconn=xcb \
+ ${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/ --disable-consolekit', '--without-systemdsystemunitdir', d)}"
+
+do_configure_prepend() {
+ cp ${STAGING_DATADIR}/gettext/po/Makefile.in.in ${S}/po/
+}
do_compile_append() {
# default background configured not available / no password field available / no default screensaver