aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/lxdm
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 14:59:30 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:22:05 +0200
commit61241113169b676b8c8c5989017262de0e9ca9b1 (patch)
treec3ae209b5409b6e25dfa8b40c6972ce1787d4533 /meta-oe/recipes-graphics/lxdm
parent2db07ef244ef4ae249e954bcda93f83052bb96a0 (diff)
downloadmeta-openembedded-contrib-61241113169b676b8c8c5989017262de0e9ca9b1.tar.gz
lxdm: move systemd support from meta-systemd back to meta-oe
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/lxdm')
-rw-r--r--meta-oe/recipes-graphics/lxdm/lxdm_git.bb12
1 files changed, 8 insertions, 4 deletions
diff --git a/meta-oe/recipes-graphics/lxdm/lxdm_git.bb b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
index be83146b0c..a6f266cc38 100644
--- a/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
+++ b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
@@ -15,19 +15,18 @@ LXDM_PAM = "${@base_contains("DISTRO_TYPE", "debug", "lxdm-pam-debug", "lxdm-pam
SRCREV = "65e7cc8fdc150c2b925eb348ce82de17dee5eb0b"
PV = "0.4.2+git${SRCPV}"
PE = "1"
-PR = "r3"
+PR = "r6"
DEPENDS = "cairo consolekit dbus gdk-pixbuf glib-2.0 gtk+ virtual/libx11 libxcb pango"
# combine oe-core way with angstrom DISTRO_TYPE
DISTRO_TYPE ?= "${@base_contains("IMAGE_FEATURES", "debug-tweaks", "debug", "",d)}"
-inherit autotools gettext
+inherit autotools gettext systemd
S = "${WORKDIR}/git"
-SYSTEMD_UNITDIR ??= "no"
-EXTRA_OECONF = "--with-systemdsystemunitdir=${SYSTEMD_UNITDIR}"
+EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}"
do_compile_append() {
# default background configured not available / no password field available / no default screensaver
@@ -66,3 +65,8 @@ sed -i "s:last_langs=.*$:last_langs=$langs:g" ${localstatedir}/lib/lxdm/lxdm.con
}
RDEPENDS_${PN} = "pam-plugin-loginuid setxkbmap"
+
+RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "lxdm.service"