aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/lxdm
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-11-21 13:16:45 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-11-29 11:03:35 +0100
commit3f2736b481787ec2b8c8b00f670cac8aae681cd4 (patch)
tree14689a6494baa2e4c0851032b7c6c0d449eacbed /meta-oe/recipes-graphics/lxdm
parent946c52ccf1cbdaa1d6337486e9ac3a1b0f3bb8a5 (diff)
downloadmeta-openembedded-contrib-3f2736b481787ec2b8c8b00f670cac8aae681cd4.tar.gz
lxdm: bugfixes by updating to latest git
* make keyboard layout combobox display languages properly * systemd-support is included mainline * autologin for timeouts < 5s works as expected Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-graphics/lxdm')
-rw-r--r--meta-oe/recipes-graphics/lxdm/lxdm_git.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta-oe/recipes-graphics/lxdm/lxdm_git.bb b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
index fd28c41c91..f3d4effa7a 100644
--- a/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
+++ b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
@@ -12,8 +12,10 @@ SRC_URI = " \
LXDM_PAM = "${@base_contains("DISTRO_TYPE", "debug", "lxdm-pam-debug", "lxdm-pam",d)}"
-SRCREV = "d681bc90b62ec2e13ed62fc30cdaf5dbbba23cdc"
+SRCREV = "65e7cc8fdc150c2b925eb348ce82de17dee5eb0b"
PV = "0.4.2+git${SRCPV}"
+PE = "1"
+PR = "r1"
DEPENDS = "cairo consolekit dbus gdk-pixbuf glib-2.0 gtk+ virtual/libx11 libxcb pango"
@@ -24,10 +26,14 @@ inherit autotools gettext
S = "${WORKDIR}/git"
+SYSTEMD_UNITDIR ??= "no"
+EXTRA_OECONF = "--with-systemdsystemunitdir=${SYSTEMD_UNITDIR}"
+
do_compile_append() {
# default background configured not available / no password field available
sed -i -e 's,bg=,# bg=,g' \
-e 's,# skip_password=,skip_password=,g' \
+ -e 's,keyboard=0,keyboard=1,g' \
${S}/data/lxdm.conf.in
# add default configuration
oe_runmake -C ${S}/data lxdm.conf
@@ -59,4 +65,4 @@ done
sed -i "s:last_langs=.*$:last_langs=$langs:g" ${localstatedir}/lib/lxdm/lxdm.conf
}
-RDEPENDS_${PN} = "pam-plugin-loginuid"
+RDEPENDS_${PN} = "pam-plugin-loginuid setxkbmap"