aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2014-10-07 08:49:45 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-10-10 12:47:35 +0200
commitc8a670fea52b8bd7c9a0476c82cb49bedb8b35f3 (patch)
tree29c503113a86a3e3cfa9c15b1125b754ce25a7e6 /meta-oe/recipes-graphics/lxdm/lxdm_git.bb
parentc734b14e2b900fe5172cc80185f0cf8b7734d0e8 (diff)
downloadmeta-openembedded-contrib-c8a670fea52b8bd7c9a0476c82cb49bedb8b35f3.tar.gz
lxdm: update to latest sources and fixes
* /etc/lxdm/lxdm.conf was empty since out of tree build causing greeter not started * pam is now an option to configure - set it based upon distro feature * bash was added to RDEPENDS - it is required by /etc/lxdm/Xsession Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/lxdm/lxdm_git.bb')
-rw-r--r--meta-oe/recipes-graphics/lxdm/lxdm_git.bb24
1 files changed, 13 insertions, 11 deletions
diff --git a/meta-oe/recipes-graphics/lxdm/lxdm_git.bb b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
index dc40fb2d3c..a3dcc1bd2f 100644
--- a/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
+++ b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
@@ -5,14 +5,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
SRC_URI = " \
git://lxde.git.sourceforge.net/gitroot/lxde/${BPN};branch=master \
file://lxdm.conf \
- file://lxdm-pam \
- file://lxdm-pam-debug \
+ ${@base_contains('DISTRO_FEATURES', 'pam', 'file://lxdm-pam file://lxdm-pam-debug', '', d)} \
${@base_contains("DISTRO_TYPE", "debug", "", "file://0001-lxdm.conf.in-blacklist-root-for-release-images.patch",d)} \
+ file://0002-let-autotools-create-lxdm.conf.patch \
"
-LXDM_PAM = "${@base_contains("DISTRO_TYPE", "debug", "lxdm-pam-debug", "lxdm-pam",d)}"
-
-SRCREV = "07fb151a99ef99318b71f3de0afbba977b1e6267"
+SRCREV = "bf90ec7df5ff6745f703500c5792c344fbaef301"
PV = "0.5.0+git${SRCPV}"
PE = "1"
@@ -29,7 +27,9 @@ S = "${WORKDIR}/git"
CFLAGS_append = " -fno-builtin-fork -fno-builtin-memset -fno-builtin-strstr "
EXTRA_OECONF += "--enable-gtk3=no --enable-password=yes --with-x -with-xconn=xcb \
- ${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/ --disable-consolekit', '--without-systemdsystemunitdir', d)}"
+ ${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/ --disable-consolekit', '--without-systemdsystemunitdir', d)} \
+ ${@base_contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)} \
+"
do_configure_prepend() {
cp ${STAGING_DATADIR}/gettext/po/Makefile.in.in ${S}/po/
@@ -48,10 +48,12 @@ do_compile_append() {
do_install_append() {
install -d ${D}${localstatedir}/lib/lxdm
install -m 644 ${WORKDIR}/lxdm.conf ${D}${localstatedir}/lib/lxdm
- # ArchLinux version of pam config has the following advantages:
- # * simple setup of passwordless login
- # * in XFCE powerdown/restart enabled in logoff dialog
- install -m 644 ${WORKDIR}/${LXDM_PAM} ${D}${sysconfdir}/pam.d/lxdm
+ if ${@base_contains('DISTRO_FEATURES', 'pam', 'true', 'false', d)}; then
+ # ArchLinux version of pam config has the following advantages:
+ # * simple setup of passwordless login
+ # * in XFCE powerdown/restart enabled in logoff dialog
+ install -m 644 ${WORKDIR}/${@base_contains("DISTRO_TYPE", "debug", "lxdm-pam-debug", "lxdm-pam",d)} ${D}${sysconfdir}/pam.d/lxdm
+ fi
}
# make installed languages choosable
@@ -68,7 +70,7 @@ done
sed -i "s:last_langs=.*$:last_langs=$langs:g" $D${localstatedir}/lib/lxdm/lxdm.conf
}
-RDEPENDS_${PN} = "pam-plugin-loginuid setxkbmap"
+RDEPENDS_${PN} = "${@base_contains('DISTRO_FEATURES', 'pam', 'pam-plugin-loginuid', '', d)} setxkbmap bash"
RPROVIDES_${PN} += "${PN}-systemd"
RREPLACES_${PN} += "${PN}-systemd"