aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/libyui/libyui_4.1.1.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-04-06 20:23:48 +0200
committerKhem Raj <raj.khem@gmail.com>2021-04-06 13:33:29 -0700
commitf825ad7d7e05bd3125580880cb9e6c1fbe959777 (patch)
treecba39d28c477dba010394f26d038b10a688a9bfe /meta-oe/recipes-graphics/libyui/libyui_4.1.1.bb
parent902919167a97055e9be9cd3654f29823e81ae382 (diff)
downloadmeta-openembedded-contrib-f825ad7d7e05bd3125580880cb9e6c1fbe959777.tar.gz
libyui(-ncurses): upgrade to 4.1.1, libyui repo was rewritten completely
* af06143017fc5f18c4b6488ba4aed26bcc43ff6e doesn't exist in current repo: libyui$ git branch -a --contains af06143017fc5f18c4b6488ba4aed26bcc43ff6e error: no such commit af06143017fc5f18c4b6488ba4aed26bcc43ff6e * there are no common commits in the new libyui repo, but luckily old repo is kept as https://github.com/libyui/libyui-old similarly libyui-ncurses now contains only README about being obsolete in: https://github.com/libyui/libyui-ncurses but at least it wasn't rewritten to have the new content * now both recipes need to use the same git repo and just different subdirs in S Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/libyui/libyui_4.1.1.bb')
-rw-r--r--meta-oe/recipes-graphics/libyui/libyui_4.1.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/libyui/libyui_4.1.1.bb b/meta-oe/recipes-graphics/libyui/libyui_4.1.1.bb
new file mode 100644
index 0000000000..acab7d4568
--- /dev/null
+++ b/meta-oe/recipes-graphics/libyui/libyui_4.1.1.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Libyui is a widget abstraction library providing Qt, GTK and ncurses frontends."
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://../COPYING.gpl-3;md5=d32239bcb673463ab874e80d47fae504 \
+ file://../COPYING.lgpl-2.1;md5=4fbd65380cdd255951079008b364516c \
+ file://../COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
+ "
+
+SRC_URI = "git://github.com/libyui/libyui.git \
+ file://0001-Fix-build-with-clang.patch \
+ file://0001-Use-relative-install-paths-for-CMake.patch \
+ "
+
+SRCREV = "718ac672374a2b0f50cbc7d637d90e6471babc3d"
+
+S = "${WORKDIR}/git/libyui"
+
+inherit cmake gettext pkgconfig
+
+DEPENDS += "boost"
+
+EXTRA_OECMAKE += "-DCMAKE_BUILD_TYPE=RELWITHDEBINFO -DWERROR=OFF"
+
+BBCLASSEXTEND = "native nativesdk"
+
+do_install_append () {
+ if [ "${libdir}" = "${base_prefix}/usr/lib" ] && [ -d ${D}/usr/lib64 ]; then
+ mv ${D}/usr/lib64 ${D}/usr/lib
+ fi
+}
+
+do_install_append_class-nativesdk () {
+ mkdir -p ${D}/${base_prefix}
+ mv ${D}/usr ${D}/${base_prefix}
+}
+
+FILES_${PN}-dev = "${libdir}/* ${includedir}/yui*"