aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/libsdl/libsdl2-image_2.0.1.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-08-16 20:27:47 +0200
committerKhem Raj <raj.khem@gmail.com>2018-08-19 16:09:28 -0700
commit23561de348d225aba3d01bb1b7355bbd43b309ba (patch)
tree321a118e9db9bc47bfb97d3aa8985b67b15ca12f /meta-oe/recipes-graphics/libsdl/libsdl2-image_2.0.1.bb
parent227b687ecd3e92f979d2297982ef72142a3c798b (diff)
downloadmeta-openembedded-contrib-23561de348d225aba3d01bb1b7355bbd43b309ba.tar.gz
move all libsdl recipes in one folder and follow oe-core's folder for libsdl
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/libsdl/libsdl2-image_2.0.1.bb')
-rw-r--r--meta-oe/recipes-graphics/libsdl/libsdl2-image_2.0.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/libsdl/libsdl2-image_2.0.1.bb b/meta-oe/recipes-graphics/libsdl/libsdl2-image_2.0.1.bb
new file mode 100644
index 0000000000..1f9c794c73
--- /dev/null
+++ b/meta-oe/recipes-graphics/libsdl/libsdl2-image_2.0.1.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Simple DirectMedia Layer image library v2"
+SECTION = "libs"
+
+LICENSE = "Zlib"
+LIC_FILES_CHKSUM = "file://COPYING.txt;md5=ec65b9778f5584a0bd8dfc17d6340ba0"
+
+DEPENDS = "tiff zlib libpng jpeg virtual/libsdl2 libwebp"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_image/release/SDL2_image-${PV}.tar.gz"
+SRC_URI[md5sum] = "d94b94555ba022fa249a53a021dc3606"
+SRC_URI[sha256sum] = "3a3eafbceea5125c04be585373bfd8b3a18f259bd7eae3efc4e6d8e60e0d7f64"
+
+S = "${WORKDIR}/SDL2_image-${PV}"
+
+inherit autotools pkgconfig
+
+# Disable the run-time loading of the libs and bring back the soname dependencies.
+EXTRA_OECONF += "--disable-jpg-shared --disable-png-shared -disable-tif-shared"
+
+do_configure_prepend() {
+ # make autoreconf happy
+ touch ${S}/NEWS ${S}/README ${S}/AUTHORS ${S}/ChangeLog
+ # Removing these files fixes a libtool version mismatch.
+ rm -f ${S}/acinclude/libtool.m4
+ rm -f ${S}/acinclude/sdl2.m4
+ rm -f ${S}/acinclude/pkg.m4
+ rm -f ${S}/acinclude/lt~obsolete.m4
+ rm -f ${S}/acinclude/ltoptions.m4
+ rm -f ${S}/acinclude/ltsugar.m4
+ rm -f ${S}/acinclude/ltversion.m4
+}