aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/jasper/jasper_2.0.33.bb
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2021-11-01 16:15:33 +0100
committerKhem Raj <raj.khem@gmail.com>2021-11-02 08:07:17 -0700
commitb6d90d59a055b05806017a3a5b9c24ee2287c120 (patch)
tree610b5446f06b2dd7d9e6a0ed667e3f14ccc214da /meta-oe/recipes-graphics/jasper/jasper_2.0.33.bb
parent04afd2bed40f55aae135d1b35d1e48d24f625016 (diff)
downloadmeta-openembedded-contrib-b6d90d59a055b05806017a3a5b9c24ee2287c120.tar.gz
jasper: upgrade 2.0.26 -> 2.0.33
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/jasper/jasper_2.0.33.bb')
-rw-r--r--meta-oe/recipes-graphics/jasper/jasper_2.0.33.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/jasper/jasper_2.0.33.bb b/meta-oe/recipes-graphics/jasper/jasper_2.0.33.bb
new file mode 100644
index 0000000000..da863b7316
--- /dev/null
+++ b/meta-oe/recipes-graphics/jasper/jasper_2.0.33.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Jpeg 2000 implementation"
+HOMEPAGE = "https://jasper-software.github.io/jasper/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a80440d1d8f17d041c71c7271d6e06eb"
+
+SRC_URI = "git://github.com/jasper-software/jasper.git;protocol=https"
+SRCREV = "fe00207dc10db1d7cc6f2757961c5c6bdfd10973"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[jpeg] = "-DJAS_ENABLE_LIBJPEG=true, -DJAS_ENABLE_LIBJPEG=false, jpeg"
+PACKAGECONFIG[opengl] = "-DJAS_ENABLE_OPENGL=true, -DJAS_ENABLE_OPENGL=false, freeglut"
+
+EXTRA_OECMAKE:append = " -DJAS_ENABLE_SHARED=true"
+
+do_install:append() {
+ chrpath -d ${D}${bindir}/jasper
+ chrpath -d ${D}${bindir}/imginfo
+ chrpath -d ${D}${bindir}/imgcmp
+ chrpath -d ${D}${libdir}/libjasper.so.*
+}