aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.4.8.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-13 11:28:00 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-13 11:28:45 +0200
commit58b79786c6b1ee26340b20e7606d2144f52543ed (patch)
treea2800f169b5d7d1600c132210b756d7518ba00a4 /meta-oe/recipes-graphics/gphoto2/libgphoto2_2.4.8.bb
parentf0dd3db640255c2af570e37e6ba3a6cb6ae61cdd (diff)
downloadmeta-openembedded-contrib-58b79786c6b1ee26340b20e7606d2144f52543ed.tar.gz
libgphoto2 2.4.8: import from OE rev a54456425ea3ce4c7cdfa958cec3ba34539cfeec
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-graphics/gphoto2/libgphoto2_2.4.8.bb')
-rw-r--r--meta-oe/recipes-graphics/gphoto2/libgphoto2_2.4.8.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.4.8.bb b/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.4.8.bb
new file mode 100644
index 0000000000..e19a6aeaf3
--- /dev/null
+++ b/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.4.8.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "libgphoto2 allows you to access digital cameras"
+SECTION = "libs"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0448d3676bc0de00406af227d341a4d1"
+
+DEPENDS = "libtool jpeg virtual/libusb0 libexif"
+
+# The .fdi and .rules files were generated with:
+# libgphoto2-2.4.7/packaging/generic$ qemu-arm -s 1048576 -r 2.6.24 -L /OE/angstrom-dev/staging/armv5te-angstrom-linux-gnueabi/ .libs/print-camera-list
+# They are release specific, so please regen when adding new releases
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/libgphoto2-${PV}.tar.bz2;name=libgphoto2 \
+ file://10-camera-libgphoto2-device.fdi \
+ file://10-camera-libgphoto2.fdi \
+ file://90-libgphoto2.rules \
+"
+
+SRC_URI[libgphoto2.md5sum] = "7753f17dff15702466337aab05209a71"
+SRC_URI[libgphoto2.sha256sum] = "69d7e0723b40e8a0c4fa897b96f6aecb5ae5548c3cce98c48e37b70623d9ffc3"
+
+inherit autotools pkgconfig gettext lib_package
+
+EXTRA_OECONF = " --with-drivers=all udevscriptdir=/lib/udev ac_cv_lib_ltdl_lt_dlcaller_register=yes"
+
+do_configure_append() {
+ cd ${S}/libgphoto2_port/
+ autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths
+ cd ${S}
+}
+
+do_install_append() {
+ install -d ${D}${datadir}/hal/fdi/information/20thirdparty
+ install -m 0644 ${WORKDIR}/*.fdi ${D}${datadir}/hal/fdi/information/20thirdparty/
+
+ install -d ${D}${sysconfdir}/udev/rules.d/
+ install -m 0755 ${WORKDIR}/*.rules ${D}${sysconfdir}/udev/rules.d/
+}
+
+PACKAGES =+ "libgphotoport libgphoto2-camlibs"
+FILES_libgphoto2-camlibs = "${libdir}/libgphoto2*/*/*.so*"
+RDEPENDS_${PN} = "libgphoto2-camlibs"
+
+FILES_libgphotoport = "${libdir}/libgphoto2_port.so.*"
+
+FILES_${PN} += "${base_libdir}/udev/* ${datadir}/hal"
+FILES_${PN}-dbg += "${libdir}/*/*/.debug"
+
+
+