aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb
diff options
context:
space:
mode:
authorAnn Thornton <ann.thornton@nxp.com>2016-09-06 17:08:57 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-15 10:22:45 +0200
commit5b4a5572650e8a20c4a5c956d1874813f81c2d1b (patch)
tree79c3cd0406ed8b087dcdda44ee9fa47c224ad969 /meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb
parentf3cd93f4bd7d77e3f75076e53bffff3425c2ee98 (diff)
downloadmeta-openembedded-contrib-5b4a5572650e8a20c4a5c956d1874813f81c2d1b.tar.gz
glcompbench: Fix issues causing failures in GCC6
Signed-off-by: Ann Thornton <ann.thornton@nxp.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb')
-rwxr-xr-x[-rw-r--r--]meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb b/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb
index 0c5d7b5fc3..35fb4adb33 100644..100755
--- a/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb
+++ b/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb
@@ -6,7 +6,10 @@ DEPENDS = "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2 \
virtual/libx11 libxcomposite pixman libxrender libpng12"
SRC_URI = "https://launchpad.net/glcompbench/trunk/${PV}/+download/${BPN}-${PV}.tar.gz \
- file://glbench-compile-fix.patch"
+ file://glbench-compile-fix.patch \
+ file://Fix-configure-for-sqrt-check.patch \
+ file://Fix_space_issues.patch \
+ file://Fix_auto_ptr_deprecated.patch"
SRC_URI[md5sum] = "c939d9156fe940960098f38707fea827"
SRC_URI[sha256sum] = "b04b738cec06c6786ceafa86e4735fd8b971c078265754854ef356b0379542ee"
@@ -14,6 +17,3 @@ SRC_URI[sha256sum] = "b04b738cec06c6786ceafa86e4735fd8b971c078265754854ef356b037
inherit pkgconfig waf distro_features_check
# depends on virtual/libx11
REQUIRED_DISTRO_FEATURES = "x11"
-
-# http://errors.yoctoproject.org/Errors/Details/68631/
-PNBLACKLIST[glcompbench] ?= "BROKEN: fails to build with gcc-6"