aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/gimp/gimp_2.8.14.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-02-12 16:06:31 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-19 10:09:59 +0100
commitc22da8be7468c140c7aa56f44b4d02c125df19b3 (patch)
treeede61d3f48b89e4c7d1dcf69a614910e98f3dd12 /meta-oe/recipes-graphics/gimp/gimp_2.8.14.bb
parenteaa248e369b5445e41e895e6894d6e2a47c917a2 (diff)
downloadmeta-openembedded-contrib-c22da8be7468c140c7aa56f44b4d02c125df19b3.tar.gz
gimp: update to 2.8.14 / fix build by not configuring with freetype-config
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/gimp/gimp_2.8.14.bb')
-rw-r--r--meta-oe/recipes-graphics/gimp/gimp_2.8.14.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/gimp/gimp_2.8.14.bb b/meta-oe/recipes-graphics/gimp/gimp_2.8.14.bb
new file mode 100644
index 0000000000..7d52cf18ef
--- /dev/null
+++ b/meta-oe/recipes-graphics/gimp/gimp_2.8.14.bb
@@ -0,0 +1,31 @@
+SUMMARY = "The GIMP is the GNU Image Manipulation Program"
+HOMEPAGE = "http://www.gimp.org"
+SECTION = "x11/graphics"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+DEPENDS = "babl gdk-pixbuf-native libart-lgpl gtk+ jpeg libpng libexif tiff lcms gegl poppler jasper bzip2"
+DEPENDS += "${@base_contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)}"
+
+inherit gnome gtk-doc
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[helpbrowser] = "--with-webkit, --without-webkit, webkit-gtk"
+
+SRC_URI = " \
+ http://ftp.gimp.org/pub/gimp/v2.8/gimp-${PV}.tar.bz2 \
+ file://0001-configure-ac-do-not-check-for-freetype-config.patch \
+"
+SRC_URI[md5sum] = "233c948203383fa078434cc3f8f925cb"
+SRC_URI[sha256sum] = "d82a958641c9c752d68e35f65840925c08e314cea90222ad845892a40e05b22d"
+
+EXTRA_OECONF = "--disable-python \
+ --without-wmf"
+
+do_configure_append() {
+ find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
+}
+
+FILES_${PN}-dbg += "${libdir}/gimp/2.0/*/.debug"
+FILES_${PN} += "${datadir}/appdata"