aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/gegl/gegl
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-18 08:26:17 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 00:01:56 +0200
commitd7363984b83c938db6f0a16ca8732bed69ca8acb (patch)
tree5f0e3968f74fb08eb5d78cbaf196dbaeeffb156c /meta-oe/recipes-graphics/gegl/gegl
parent8dc1763bac8c42bb2d3f920ad2095d5467eebbf0 (diff)
downloadmeta-openembedded-contrib-d7363984b83c938db6f0a16ca8732bed69ca8acb.tar.gz
gegl: Use pkg-config for SDL
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-oe/recipes-graphics/gegl/gegl')
-rw-r--r--meta-oe/recipes-graphics/gegl/gegl/pkgconfig.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/gegl/gegl/pkgconfig.patch b/meta-oe/recipes-graphics/gegl/gegl/pkgconfig.patch
new file mode 100644
index 0000000000..d145b625f6
--- /dev/null
+++ b/meta-oe/recipes-graphics/gegl/gegl/pkgconfig.patch
@@ -0,0 +1,21 @@
+Index: gegl-0.2.0/configure.ac
+===================================================================
+--- gegl-0.2.0.orig/configure.ac 2012-04-02 21:56:49.000000000 +0000
++++ gegl-0.2.0/configure.ac 2014-07-17 21:34:15.312546602 +0000
+@@ -765,15 +765,7 @@
+
+ have_sdl="no"
+ if test "x$with_sdl" != "xno"; then
+- AC_PATH_PROG(SDL_CONFIG, sdl-config, no)
+- if test "$SDL_CONFIG" = "no"; then
+- have_sdl="no (SDL library not found)"
+- AC_MSG_RESULT([*** Check for SDL library failed.])
+- else
+- have_sdl="yes"
+- SDL_CFLAGS=`$SDL_CONFIG --cflags`
+- SDL_LIBS=`$SDL_CONFIG --libs`
+- fi
++ PKG_CHECK_MODULES([SDL], [sdl], [have_sdl="yes"], [have_sdl="no (SDL library not found)"])
+ fi
+
+ AM_CONDITIONAL(HAVE_SDL, test "$have_sdl" = "yes")