aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-gnome
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2020-06-12 17:11:58 +0100
committerKhem Raj <raj.khem@gmail.com>2020-06-13 21:34:21 -0700
commit5fb2893684df6f005f8f5a98be74cfc424247343 (patch)
treef09a80723d90c1554e0283ccd6254c53bce1daa4 /meta-oe/recipes-gnome
parentf6aa84fcf197bb74ed2a4dc1e3bb898fc884e27b (diff)
downloadmeta-openembedded-contrib-5fb2893684df6f005f8f5a98be74cfc424247343.tar.gz
libxmlb: Add recipe
Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-gnome')
-rw-r--r--meta-oe/recipes-gnome/libxmlb/libxmlb/run-ptest3
-rw-r--r--meta-oe/recipes-gnome/libxmlb/libxmlb_0.1.15.bb19
2 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-gnome/libxmlb/libxmlb/run-ptest b/meta-oe/recipes-gnome/libxmlb/libxmlb/run-ptest
new file mode 100644
index 0000000000..6d0bb95d3a
--- /dev/null
+++ b/meta-oe/recipes-gnome/libxmlb/libxmlb/run-ptest
@@ -0,0 +1,3 @@
+#! /bin/sh
+
+gnome-desktop-testing-runner libxmlb
diff --git a/meta-oe/recipes-gnome/libxmlb/libxmlb_0.1.15.bb b/meta-oe/recipes-gnome/libxmlb/libxmlb_0.1.15.bb
new file mode 100644
index 0000000000..c545993174
--- /dev/null
+++ b/meta-oe/recipes-gnome/libxmlb/libxmlb_0.1.15.bb
@@ -0,0 +1,19 @@
+SUMMARY = "A library to help create and query binary XML blobs"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1803fa9c2c3ce8cb06b4861d75310742"
+
+SRC_URI = "\
+ git://github.com/hughsie/libxmlb.git \
+ file://run-ptest \
+"
+SRCREV = "ee4aafdd97844f1c73021a4978a43460f0835d5c"
+S = "${WORKDIR}/git"
+
+inherit gobject-introspection gtk-doc meson ptest-gnome
+
+PACKAGECONFIG ??= "\
+ ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
+"
+PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false"
+
+GTKDOC_MESON_OPTION = "gtkdoc"