aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-gnome
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2017-07-28 16:02:59 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-31 15:22:57 +0200
commitec1781e98fd49733c60f9c162b15eaf50c2e46dd (patch)
treec37742bcc5ca2690faed31e2ff107a1ff597b3ad /meta-oe/recipes-gnome
parentd802d780321f47fb691626286d60f3e7a2f70057 (diff)
downloadmeta-openembedded-contrib-ec1781e98fd49733c60f9c162b15eaf50c2e46dd.tar.gz
autoconf-archive: move from meta-oe to OE-core
This complements the corresponding patch in OE-core. gnome-common is affected and must be modified together with the move because of the conflict over who provides ax_code_coverage.m4 and ax_check_enable_debug.m4. They now come from autoconf-archive in OE-core. Signed-off-by: Patrick Ohly <patrick.ohly@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-gnome')
-rw-r--r--meta-oe/recipes-gnome/gnome-common/gnome-common_3.18.0.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-oe/recipes-gnome/gnome-common/gnome-common_3.18.0.bb b/meta-oe/recipes-gnome/gnome-common/gnome-common_3.18.0.bb
index 06f3bb34cf..b8b9ef1222 100644
--- a/meta-oe/recipes-gnome/gnome-common/gnome-common_3.18.0.bb
+++ b/meta-oe/recipes-gnome/gnome-common/gnome-common_3.18.0.bb
@@ -17,4 +17,15 @@ DEPENDS = ""
FILES_${PN} += "${datadir}/aclocal"
FILES_${PN}-dev = ""
+# ax_code_coverage.m4 and ax_check_enable_debug.m4 are in gnome-common only
+# because older versions of autoconf-archive didn't have them yet. Now they
+# are in autoconf-archive from OE-core. We depend on that below to ensure
+# that recipes which only depend on gnome-common still get them.
+do_install_append () {
+ rm -f ${D}${datadir}/aclocal/ax_code_coverage.m4
+ rm -f ${D}${datadir}/aclocal/ax_check_enable_debug.m4
+}
+RDEPENDS_${PN} += "autoconf-archive"
+DEPENDS_append_class-native = " autoconf-archive-native"
+
BBCLASSEXTEND = "native"