aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-gnome/gtk+/gtk+/hardcoded_libtool.patch
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-07-11 11:04:20 +0100
committerKhem Raj <raj.khem@gmail.com>2019-07-11 14:01:28 -0700
commit4362a953e4ee50314ccdd994cb7cf625ee988441 (patch)
tree3a336e3af0b7ec4ce981f0d679bbdc271efcbd30 /meta-oe/recipes-gnome/gtk+/gtk+/hardcoded_libtool.patch
parentb0f86ee5a98d197afe32f1325d92ea2fa2e4b56d (diff)
downloadmeta-openembedded-contrib-4362a953e4ee50314ccdd994cb7cf625ee988441.tar.gz
gtk+: add (from oe-core)
This is GTK+ 2, which is obsolete. It has just been removed from oe-core, so add it into meta-oe for any remaining users. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-gnome/gtk+/gtk+/hardcoded_libtool.patch')
-rw-r--r--meta-oe/recipes-gnome/gtk+/gtk+/hardcoded_libtool.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-gnome/gtk+/gtk+/hardcoded_libtool.patch b/meta-oe/recipes-gnome/gtk+/gtk+/hardcoded_libtool.patch
new file mode 100644
index 0000000000..9eb7f6bf5c
--- /dev/null
+++ b/meta-oe/recipes-gnome/gtk+/gtk+/hardcoded_libtool.patch
@@ -0,0 +1,36 @@
+Upstream-Status: Inappropriate [embedded specific]
+
+Updated to apply to gtk+-2.24.15
+
+Signed-off-by: Marko Lindqvist <cazfi74@gmail.com>
+Index: gtk+-2.24.31/configure.ac
+===================================================================
+--- gtk+-2.24.31.orig/configure.ac
++++ gtk+-2.24.31/configure.ac
+@@ -415,7 +415,7 @@ AC_MSG_CHECKING([Whether to write depend
+ case $enable_explicit_deps in
+ auto)
+ export SED
+- deplibs_check_method=`(./libtool --config; echo 'eval echo \"$deplibs_check_method\"') | sh`
++ deplibs_check_method=`(./$host_alias-libtool --config; echo 'eval echo \"$deplibs_check_method\"') | sh`
+ if test "x$deplibs_check_method" '!=' xpass_all || test "x$enable_static" = xyes ; then
+ enable_explicit_deps=yes
+ else
+@@ -772,7 +772,7 @@ else
+ dnl Now we check to see if our libtool supports shared lib deps
+ dnl (in a rather ugly way even)
+ if $dynworks; then
+- module_libtool_config="${CONFIG_SHELL-/bin/sh} ./libtool --config"
++ module_libtool_config="${CONFIG_SHELL-/bin/sh} $host_alias-libtool --config"
+ module_deplibs_check=`$module_libtool_config | \
+ grep '^[[a-z_]]*check[[a-z_]]*_method=[['\''"]]' | \
+ sed 's/.*[['\''"]]\(.*\)[['\''"]]$/\1/'`
+@@ -1579,7 +1579,7 @@ fi
+ # We are using gmodule-no-export now, but I'm leaving the stripping
+ # code in place for now, since pango and atk still require gmodule.
+ export SED
+-export_dynamic=`(./libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
++export_dynamic=`($host_alias-libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
+ if test -n "$export_dynamic"; then
+ GDK_DEP_LIBS=`echo $GDK_DEP_LIBS | sed -e "s/$export_dynamic//"`
+ GTK_DEP_LIBS=`echo $GTK_DEP_LIBS | sed -e "s/$export_dynamic//"`