aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorPeter Kjellerstedt <pkj@axis.com>2023-11-07 08:12:28 +0100
committerKhem Raj <raj.khem@gmail.com>2023-11-07 19:59:58 -0800
commitf747ee50b2893f5226d0e1ce552b315d765505b9 (patch)
treed649c93cc340a8563062f59e334c377cbc56e6e9 /meta-oe/recipes-extended
parent61603d4dce0f47a7027c4fe2c0d0f677f7d05b53 (diff)
downloadmeta-openembedded-contrib-f747ee50b2893f5226d0e1ce552b315d765505b9.tar.gz
mstpd: Update to 0.1.0+
The "update" to 0.05 in commit d0dbeb580f was actually a revert, since version "0.05" in reality corresponds to "0.0.5". Also do some clean up: * Unify SRC_URI. * Correct the indentation of shell code. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/networking/mstpd_git.bb26
1 files changed, 14 insertions, 12 deletions
diff --git a/meta-oe/recipes-extended/networking/mstpd_git.bb b/meta-oe/recipes-extended/networking/mstpd_git.bb
index ed5669e55e..b2043ef062 100644
--- a/meta-oe/recipes-extended/networking/mstpd_git.bb
+++ b/meta-oe/recipes-extended/networking/mstpd_git.bb
@@ -1,15 +1,17 @@
-PV = "0.05"
LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4325afd396febcb659c36b49533135d4"
-SRC_URI = "git://github.com/mstpd/mstpd;branch=master;protocol=https"
+PV = "0.1.0+git"
+
+SRC_URI = " \
+ git://github.com/mstpd/mstpd;branch=master;protocol=https \
+ file://bridge-stp \
+ file://mstpd.service \
+"
SRCREV = "181c453fc1a00573e19f14960dcc54ad84beea7c"
S = "${WORKDIR}/git"
-SRC_URI:append = " \
- file://bridge-stp \
- file://mstpd.service \
-"
+UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+){2,})"
inherit autotools pkgconfig systemd
@@ -20,12 +22,12 @@ SYSTEMD_PACKAGES = "${PN}-mstpd"
SYSTEMD_SERVICE:${PN}-mstpd = "mstpd.service"
do_install:append() {
- rm -rf ${D}${libexecdir} ${D}${libdir}/NetworkManager
- rmdir ${D}${libdir} || true
+ rm -rf ${D}${libexecdir} ${D}${libdir}/NetworkManager
+ rmdir ${D}${libdir} || true
- install -d -m 0755 ${D}/${sbindir}
- install -m 0755 ${WORKDIR}/bridge-stp ${D}/${sbindir}
+ install -d -m 0755 ${D}${sbindir}
+ install -m 0755 ${WORKDIR}/bridge-stp ${D}${sbindir}
- install -d -m 0755 ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/mstpd.service ${D}${systemd_system_unitdir}/
+ install -d -m 0755 ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/mstpd.service ${D}${systemd_system_unitdir}
}