aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorDavid Sterling <david-sterling@users.noreply.github.com>2021-06-28 13:38:30 +0200
committerKhem Raj <raj.khem@gmail.com>2021-07-16 08:58:27 -0700
commitbb9be0af4abbea8805181f5ee151725cd7bd69f9 (patch)
tree4eed9878340d4004347958445a2fe63d5947fc4c /meta-oe/recipes-extended
parent1860045b86838b70248bf61e85e0ca3143150b9a (diff)
downloadmeta-openembedded-contrib-bb9be0af4abbea8805181f5ee151725cd7bd69f9.tar.gz
can-isotp: Upgrade to latest on master
It is needed for 5.2 to 5.10 kernel Can-isotp is now upstream from kernel 5.10 onwards. Use kernel config file instead. This is only provided for legacy kernels. For kernel 5.10 onwards use kernel defconfig option for ISO 15765-2 CAN transport and do not use can-isotp recipe. You will get "The file /usr/include/linux/can/isotp.h is installed by both linux-libc-headers and can-isotp" error using this recipe with kernel >= 5.10 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/socketcan/can-isotp_git.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/socketcan/can-isotp_git.bb b/meta-oe/recipes-extended/socketcan/can-isotp_git.bb
index eca8dfc7b7..72d6757804 100644
--- a/meta-oe/recipes-extended/socketcan/can-isotp_git.bb
+++ b/meta-oe/recipes-extended/socketcan/can-isotp_git.bb
@@ -1,14 +1,17 @@
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=72d977d697c3c05830fdff00a7448931"
-SRCREV = "b31bce98d65f894aad6427bcf6f3f7822e261a59"
+SRCREV = "beb4650660179963a8ed5b5cbf2085cc1b34f608"
PV = "1.0+git${SRCPV}"
SRC_URI = "git://github.com/hartkopp/can-isotp.git;protocol=https"
+
S = "${WORKDIR}/git"
inherit module
EXTRA_OEMAKE += "KERNELDIR=${STAGING_KERNEL_DIR}"
-PNBLACKLIST[can-isotp] ?= "Kernel module Needs forward porting to kernel 5.2+"
+do_install_append() {
+ install -Dm 644 ${S}/include/uapi/linux/can/isotp.h ${D}${includedir}/linux/can/isotp.h
+}