aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-12-02 08:08:52 -0800
committerKhem Raj <raj.khem@gmail.com>2023-12-02 08:10:26 -0800
commit8dba0c9bad9e7adee59b5697e0ad5d153f63ee55 (patch)
treec0abc5a822bcc92ca9041757385f93904ee33ece /meta-oe/recipes-extended
parentf5279055e59056fac64d0d4424f809831896c955 (diff)
downloadmeta-openembedded-contrib-8dba0c9bad9e7adee59b5697e0ad5d153f63ee55.tar.gz
liblognorm:Add asprintf to autoconf function check macro
Fix build error found with clang-17 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/liblognorm/liblognorm/0001-Add-asprintf-to-autoconf-function-check-macro.patch28
-rw-r--r--meta-oe/recipes-extended/liblognorm/liblognorm_2.0.6.bb4
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/liblognorm/liblognorm/0001-Add-asprintf-to-autoconf-function-check-macro.patch b/meta-oe/recipes-extended/liblognorm/liblognorm/0001-Add-asprintf-to-autoconf-function-check-macro.patch
new file mode 100644
index 0000000000..abb09bc648
--- /dev/null
+++ b/meta-oe/recipes-extended/liblognorm/liblognorm/0001-Add-asprintf-to-autoconf-function-check-macro.patch
@@ -0,0 +1,28 @@
+From b8c65236cd6cd68b57004479006c683455680a82 Mon Sep 17 00:00:00 2001
+From: Alfred Wingate <parona@protonmail.com>
+Date: Sun, 15 Oct 2023 12:34:52 +0100
+Subject: [PATCH] Add asprintf to autoconf function check macro
+
+Upstream-Status: Submitted [https://github.com/rsyslog/liblognorm/pull/376]
+Signed-off-by: Alfred Wingate <parona@protonmail.com>
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index b6f92f1..b057550 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -55,7 +55,7 @@ AC_TYPE_SIZE_T
+ AC_FUNC_SELECT_ARGTYPES
+ AC_TYPE_SIGNAL
+ AC_FUNC_STRERROR_R
+-AC_CHECK_FUNCS([strdup strndup strtok_r])
++AC_CHECK_FUNCS([asprintf strdup strndup strtok_r])
+
+ LIBLOGNORM_CFLAGS="-I\$(top_srcdir)/src"
+ LIBLOGNORM_LIBS="\$(top_builddir)/src/liblognorm.la"
+--
+2.43.0
+
diff --git a/meta-oe/recipes-extended/liblognorm/liblognorm_2.0.6.bb b/meta-oe/recipes-extended/liblognorm/liblognorm_2.0.6.bb
index f9196af92d..0cc128c8c4 100644
--- a/meta-oe/recipes-extended/liblognorm/liblognorm_2.0.6.bb
+++ b/meta-oe/recipes-extended/liblognorm/liblognorm_2.0.6.bb
@@ -8,7 +8,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ca016db57e008528dace002188c73dad"
DEPENDS = "libfastjson libestr"
-SRC_URI = "git://github.com/rsyslog/liblognorm;branch=master;protocol=https"
+SRC_URI = "git://github.com/rsyslog/liblognorm;branch=master;protocol=https \
+ file://0001-Add-asprintf-to-autoconf-function-check-macro.patch \
+ "
SRCREV = "46c6ee4c8e5f827893e485a4ef1aff04ea881273"
S = "${WORKDIR}/git"