aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-11-17 09:51:39 +0100
committerKhem Raj <raj.khem@gmail.com>2023-11-20 09:30:38 -0800
commit4f84234a272666e49579bc7468d67b257260c221 (patch)
treeeac7c4f6d9f13b32283c34dc14901d2ee9f1d829 /meta-oe/recipes-extended
parentdd0676e657e2f7dc84c8af7d97be01a2233f7496 (diff)
downloadmeta-openembedded-contrib-4f84234a272666e49579bc7468d67b257260c221.tar.gz
fluentbit: drop ${PE}, ${PR} from /usr/src/debug paths
Signed-off-by: Martin Jansa <martin.jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit_1.9.7.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit_1.9.7.bb b/meta-oe/recipes-extended/fluentbit/fluentbit_1.9.7.bb
index 26238e51f1..fc06095475 100644
--- a/meta-oe/recipes-extended/fluentbit/fluentbit_1.9.7.bb
+++ b/meta-oe/recipes-extended/fluentbit/fluentbit_1.9.7.bb
@@ -45,7 +45,7 @@ DEPENDS:append:libc-musl = " fts "
# flex hardcodes the input file in #line directives leading to TMPDIR contamination of debug sources.
do_compile:append() {
- find ${B} -name '*.c' -or -name '*.h' | xargs sed -i -e 's|${TMPDIR}|/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/|g'
+ find ${B} -name '*.c' -or -name '*.h' | xargs sed -i -e 's|${TMPDIR}|${TARGET_DBGSRC_DIR}/|g'
}
PACKAGECONFIG ?= "yaml"
@@ -88,5 +88,5 @@ inherit cmake systemd pkgconfig
SYSTEMD_SERVICE:${PN} = "td-agent-bit.service"
-EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/"
+EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=${TARGET_DBGSRC_DIR}/"
TARGET_CC_ARCH += " ${SELECTED_OPTIMIZATION}"