aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorJamin Lin <jamin_lin@aspeedtech.com>2023-11-06 17:02:48 +0800
committerKhem Raj <raj.khem@gmail.com>2023-11-06 08:56:02 -0800
commit1b4ce73a49509e82ad711d7a617588ca628daa0b (patch)
tree863faa8ca542f0ee6672cdbc05bb7ed26b28e2f0 /meta-oe/recipes-extended
parent234764ef9788bc424d57124ac9fbf764e96ad9dc (diff)
downloadmeta-openembedded-contrib-1b4ce73a49509e82ad711d7a617588ca628daa0b.tar.gz
Brotli: fix build failed if the path includes "-static"
It would like to remove "-static" in the name of statice library at the do_install task. For example: replace libbrotlicommon-static.a with ibbrotlicommon-static.a However, if the patch of this statice library includes "-static", it would build failed. (ex: set my build directory "build-static") Change to remove "-static" in the base name of static library to fix this build failed. Signed-off-by: Jamin Lin <jamin_lin@aspeedtech.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/brotli/brotli_1.0.9.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb b/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb
index 4e2813dded..708c1c194a 100644
--- a/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb
+++ b/meta-oe/recipes-extended/brotli/brotli_1.0.9.bb
@@ -16,7 +16,8 @@ inherit cmake lib_package
do_install:append () {
for lib in $(ls ${D}${libdir}/*-static.a); do
- mv -v "${lib}" "$(echo ${lib} | sed s/-static//)"
+ basename=$(basename ${lib})
+ mv -v "${lib}" "${D}${libdir}/$(echo ${basename} | sed s/-static//)"
done
}