aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-02-01 14:23:40 +0000
committerJoe MacDonald <joe_macdonald@mentor.com>2018-03-05 11:45:40 -0500
commit0db9697dc6b8cb470cd97377638af69dc1052189 (patch)
treec22262d4a8729e2b9de0afdb0f070ffee59a13f7 /meta-oe/recipes-extended
parent29e280ee11c9a6f13c004ff25299668e4616f275 (diff)
downloadmeta-openembedded-contrib-0db9697dc6b8cb470cd97377638af69dc1052189.tar.gz
samba, openwsman, pam-ssh-agent-auth, sblim-sfcb, passwdqc, python-pam, smbnetfs: require pam in DISTRO_FEATURES
* there is explicit dependency on libpam without respecting pam in DISTRO_FEATURES so add the check to prevent people building it against broken libpam Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb3
-rw-r--r--meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb3
-rw-r--r--meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb3
3 files changed, 9 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb b/meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb
index c4778ca38a..f618f02b5d 100644
--- a/meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb
+++ b/meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb
@@ -12,6 +12,9 @@ SECTION = "Applications/System"
DEPENDS = "curl libxml2 openssl libpam"
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "pam"
+
SRCREV = "feb7ec9b004fcaea0dbe65ce8a1a79cc29dd994c"
PV = "2.6.3"
diff --git a/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb b/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb
index ff88533ff0..1638c41c88 100644
--- a/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb
+++ b/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb
@@ -13,6 +13,9 @@ SRC_URI[sha256sum] = "3c53d358d6eaed1b211239df017c27c6f9970995d14102ae67bae16d4f
DEPENDS += "libpam openssl"
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "pam"
+
# This gets us ssh-agent, which we are almost certain to want.
#
RDEPENDS_${PN} += "openssh-misc"
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
index c6b9f1019b..152ae22902 100644
--- a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
+++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
@@ -11,6 +11,9 @@ LICENSE = "EPL-1.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=f300afd598546add034364cd0a533261"
DEPENDS = "curl libpam openssl sblim-sfc-common unzip-native"
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "pam"
+
SRC_URI = "http://downloads.sourceforge.net/sblim/${BP}.tar.bz2 \
file://sfcb.service \
file://sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch \