aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-07-27 13:05:04 -0700
committerKhem Raj <raj.khem@gmail.com>2019-07-28 17:11:17 -0700
commit3270d14d587e9484051afe8d23068e21d7d30fcd (patch)
tree2a375d77aed37512e07a4690f24dcf338d12e540 /meta-oe/recipes-extended
parent087b917aaf538510db166bee036734ab463bb279 (diff)
downloadmeta-openembedded-contrib-3270d14d587e9484051afe8d23068e21d7d30fcd.tar.gz
pegtl: Fix build with clang/libc++
Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Ayoub Zaki <ayoub.zaki@embexus.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/pegtl/pegtl/0001-Fix-clang-warning-about-non-virtual-dtor.patch25
-rw-r--r--meta-oe/recipes-extended/pegtl/pegtl_2.1.4.bb4
2 files changed, 28 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/pegtl/pegtl/0001-Fix-clang-warning-about-non-virtual-dtor.patch b/meta-oe/recipes-extended/pegtl/pegtl/0001-Fix-clang-warning-about-non-virtual-dtor.patch
new file mode 100644
index 0000000000..0c79c4c094
--- /dev/null
+++ b/meta-oe/recipes-extended/pegtl/pegtl/0001-Fix-clang-warning-about-non-virtual-dtor.patch
@@ -0,0 +1,25 @@
+From 340110292b35d367205953a59e7eab28e1f4a0bb Mon Sep 17 00:00:00 2001
+From: Daniel Frey <d.frey@gmx.de>
+Date: Sat, 7 Apr 2018 09:13:51 +0200
+Subject: [PATCH] Fix clang-warning about non-virtual dtor
+
+Upstream-Status: Backport [https://github.com/taocpp/PEGTL/commit/340110292b35d367205953a59e7eab28e1f4a0bb]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/example/pegtl/json_classes.hpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/src/example/pegtl/json_classes.hpp
++++ b/src/example/pegtl/json_classes.hpp
+@@ -34,10 +34,7 @@ namespace examples
+ : type( in_type )
+ {
+ }
+-
+- ~json_base()
+- {
+- }
++ virtual ~json_base() = default;
+ };
+
+ inline std::ostream& operator<<( std::ostream& o, const json_base& j )
diff --git a/meta-oe/recipes-extended/pegtl/pegtl_2.1.4.bb b/meta-oe/recipes-extended/pegtl/pegtl_2.1.4.bb
index f41eef2a01..344a805245 100644
--- a/meta-oe/recipes-extended/pegtl/pegtl_2.1.4.bb
+++ b/meta-oe/recipes-extended/pegtl/pegtl_2.1.4.bb
@@ -4,7 +4,9 @@ LICENSE="MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=80cb066ab204c7fe022f1cfe0c2c6818"
SRCREV = "776fa4a1e8bda860008524f6dd9473967c8375b1"
-SRC_URI = "git://git@github.com/taocpp/PEGTL.git;protocol=https;branch=master"
+SRC_URI = "git://git@github.com/taocpp/PEGTL.git;protocol=https;branch=master \
+ file://0001-Fix-clang-warning-about-non-virtual-dtor.patch \
+ "
inherit cmake