aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-10-05 09:08:37 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-10-10 12:47:34 +0200
commit3f0c898617248f18facd949b8ffdb39e5abbd21f (patch)
tree6ba24b2853f3c9896c41ad0eb3ef2c87d24c322c /meta-oe/recipes-extended
parent784af04f2b2fc7600eb1d07bcf9adabdb2ae4561 (diff)
downloadmeta-openembedded-contrib-3f0c898617248f18facd949b8ffdb39e5abbd21f.tar.gz
subsurface: blacklist until it's upgraded for libdivecomputer compatibility
* I've started with upgrade, but requires lot more changes which I'm not comfortable to finish on something I cannot test in runtime Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/subsurface/subsurface/libm.patch17
-rw-r--r--meta-oe/recipes-extended/subsurface/subsurface/pkgconfig.patch22
-rw-r--r--meta-oe/recipes-extended/subsurface/subsurface_git.bb25
3 files changed, 7 insertions, 57 deletions
diff --git a/meta-oe/recipes-extended/subsurface/subsurface/libm.patch b/meta-oe/recipes-extended/subsurface/subsurface/libm.patch
deleted file mode 100644
index 79956089df..0000000000
--- a/meta-oe/recipes-extended/subsurface/subsurface/libm.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-| /media/build1/poky/build1/tmp/sysroots/x86_64-linux/usr/libexec/i586-poky-linux/gcc/i586-poky-linux/4.9.0/ld: divelist.o: undefined reference to symbol 'pow@@GLIBC_2.0'
-| /media/build1/poky/build1/tmp/sysroots/qemux86/lib/libm.so.6: error adding symbols: DSO missing from command line
-| collect2: error: ld returned 1 exit status
-
-Index: git/Makefile
-===================================================================
---- git.orig/Makefile 2014-07-17 20:59:03.152489041 +0000
-+++ git/Makefile 2014-07-17 20:59:19.020489473 +0000
-@@ -50,7 +50,7 @@
- LIBDIVECOMPUTERCFLAGS = -I$(LIBDIVECOMPUTERINCLUDES)
- LIBDIVECOMPUTER = $(LIBDIVECOMPUTERARCHIVE) $(LIBUSB)
-
--LIBS = $(LIBXML2) $(LIBGTK) $(LIBDIVECOMPUTER) -lpthread
-+LIBS = $(LIBXML2) $(LIBGTK) $(LIBDIVECOMPUTER) -lpthread -lm
-
- OBJS = main.o dive.o profile.o info.o equipment.o divelist.o \
- parse-xml.o save-xml.o libdivecomputer.o print.o uemis.o \
diff --git a/meta-oe/recipes-extended/subsurface/subsurface/pkgconfig.patch b/meta-oe/recipes-extended/subsurface/subsurface/pkgconfig.patch
deleted file mode 100644
index 1f294fc88f..0000000000
--- a/meta-oe/recipes-extended/subsurface/subsurface/pkgconfig.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: git/Makefile
-===================================================================
---- git.orig/Makefile 2014-07-17 20:53:23.620479788 +0000
-+++ git/Makefile 2014-07-17 20:56:07.992484267 +0000
-@@ -45,7 +45,7 @@
- # about it if it doesn't.
- LIBUSB = $(shell pkg-config --libs libusb-1.0 2> /dev/null)
-
--LIBXML2 = $(shell xml2-config --libs)
-+LIBXML2 = $(shell pkg-config --libs libxml-2.0)
- LIBGTK = $(shell pkg-config --libs gtk+-2.0 glib-2.0 gconf-2.0)
- LIBDIVECOMPUTERCFLAGS = -I$(LIBDIVECOMPUTERINCLUDES)
- LIBDIVECOMPUTER = $(LIBDIVECOMPUTERARCHIVE) $(LIBUSB)
-@@ -71,7 +71,7 @@
- $(INSTALL) $(MANFILES) $(MANDIR)
-
- parse-xml.o: parse-xml.c dive.h
-- $(CC) $(CFLAGS) `pkg-config --cflags glib-2.0` -c `xml2-config --cflags` parse-xml.c
-+ $(CC) $(CFLAGS) `pkg-config --cflags glib-2.0` -c `pkg-config --cflags libxml-2.0` parse-xml.c
-
- save-xml.o: save-xml.c dive.h
- $(CC) $(CFLAGS) `pkg-config --cflags glib-2.0` -c save-xml.c
diff --git a/meta-oe/recipes-extended/subsurface/subsurface_git.bb b/meta-oe/recipes-extended/subsurface/subsurface_git.bb
index fc50eb6806..1edb19e355 100644
--- a/meta-oe/recipes-extended/subsurface/subsurface_git.bb
+++ b/meta-oe/recipes-extended/subsurface/subsurface_git.bb
@@ -4,29 +4,18 @@ LIC_FILES_CHKSUM = "file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "libdivecomputer gtk+ libxml2 glib-2.0 gconf"
-inherit gtk-icon-cache
+PNBLACKLIST[subsurface] = "Needs to be upgraded for compatibility with new libdivecomputer"
+
+inherit gtk-icon-cache cmake
inherit gitpkgv
PKGV = "${GITPKGVTAG}"
-PV = "1.1"
+PV = "4.2"
-SRCREV = "bd275d73ac06823619230915a3aa29deddc996fb"
-SRC_URI = "git://subsurface.hohndel.org/subsurface.git \
- file://pkgconfig.patch \
- file://libm.patch"
+SRCREV = "f61ee20ba356ecfc4c5b247f548f52d588179c94"
+SRC_URI = "git://subsurface.hohndel.org/subsurface.git"
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = "CC='${CC}' \
- libdc-usr=${STAGING_INCDIR}/libdivecomputer/* \
- LIBDIVECOMPUTERINCLUDES=${STAGING_INCDIR}/libdivecomputer \
- LIBDIVECOMPUTERARCHIVE=${STAGING_LIBDIR}/libdivecomputer.a \
-"
-
-do_install() {
- oe_runmake install DESTDIR=${D}
- rm ${D}${datadir}/icons/hicolor/icon-theme.cache
-}
-
-FILES_${PN} += "${datadir}/icons/hicolor/scalable/apps/subsurface.svg"
+#FILES_${PN} += "${datadir}/icons/hicolor/scalable/apps/subsurface.svg"
RRECOMMENDS_${PN}_append_libc-glibc = " glibc-gconv-iso8859-15"