aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorRuslan Bilovol <rbilovol@cisco.com>2019-08-07 15:30:07 +0300
committerKhem Raj <raj.khem@gmail.com>2019-08-08 10:04:23 -0700
commita8ed1f33d722149206add75c8c233f2698f72f09 (patch)
tree913a5c35f832117317273f869cb25f950dd31462 /meta-oe/recipes-extended
parentc79bce945c38acab06b757b57a46ff5aa34e830c (diff)
downloadmeta-openembedded-contrib-a8ed1f33d722149206add75c8c233f2698f72f09.tar.gz
libnss-nisplus: Add recipe
Same as with libnss-nis - this will substitute the glibc nisplus module which has been removed SRCREV points to 1.3 release plus patch on top which allows to build with recent glibc versions Signed-off-by: Ruslan Bilovol <rbilovol@cisco.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/libnss-nisplus/libnss-nisplus.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libnss-nisplus/libnss-nisplus.bb b/meta-oe/recipes-extended/libnss-nisplus/libnss-nisplus.bb
new file mode 100644
index 0000000000..2dbeee7c31
--- /dev/null
+++ b/meta-oe/recipes-extended/libnss-nisplus/libnss-nisplus.bb
@@ -0,0 +1,31 @@
+# Copyright (C) 2019 Ruslan Bilovol <rbilovol@cisco.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "NSS module for glibc, to provide NIS+ support for glibc"
+
+DESCRIPTION = "This package contains the NSS NIS+ plugin for glibc.\
+This code was formerly part of glibc, but is now standalone to\
+be able to link against TI-RPC for IPv6 support."
+
+HOMEPAGE = "https://github.com/thkukuk/libnss_nisplus"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+SECTION = "libs"
+DEPENDS += "libtirpc libnsl2"
+
+PV = "1.3+git${SRCPV}"
+
+SRCREV = "c6934373c7bac91499ff7bbe7d2439599325ca63"
+
+SRC_URI = "git://github.com/thkukuk/libnss_nisplus \
+ "
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+BBCLASSEXTEND += "native nativesdk"
+#
+# We will skip parsing this packagegeoup for non-glibc systems
+#
+COMPATIBLE_HOST_libc-musl = 'null'