aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-08-16 10:39:54 +0000
committerKhem Raj <raj.khem@gmail.com>2019-08-17 01:42:54 -0700
commit803dd59f72a7cfe12e8ca8d5c8e34b1530edac0c (patch)
treea1ab3542fbbfed37e7e78448bfe26a85b2895401 /meta-oe/recipes-extended
parent586181f2d8b99b8dfdf1292169c4d56494fa9427 (diff)
downloadmeta-openembedded-contrib-803dd59f72a7cfe12e8ca8d5c8e34b1530edac0c.tar.gz
libcec: add runtime dependency on python3-core
* fixes: ERROR: QA Issue: /usr/bin/pyCecClient contained in package libcec-tools requires /usr/bin/python3, but no providers found in RDEPENDS_libcec-tools? [file-rdeps] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/libcec/libcec_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/libcec/libcec_git.bb b/meta-oe/recipes-extended/libcec/libcec_git.bb
index 26664255d2..eaf6b9b437 100644
--- a/meta-oe/recipes-extended/libcec/libcec_git.bb
+++ b/meta-oe/recipes-extended/libcec/libcec_git.bb
@@ -22,7 +22,7 @@ inherit cmake pkgconfig
# Put client tools into a separate package
PACKAGE_BEFORE_PN += "${PN}-tools"
FILES_${PN}-tools = "${bindir}"
-RDEPENDS_${PN}-tools = "python3-${BPN}"
+RDEPENDS_${PN}-tools = "python3-${BPN} python3-core"
# Create the wrapper for python3
PACKAGES += "python3-${BPN}"