aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-12-15 19:59:45 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-26 08:23:25 +0100
commiteb18c5dfa9fd736c454d65301e8512a1b043738f (patch)
tree34fd473ec93fbeba21a1b7afe0bc3ad2d7f9f38c /meta-oe/recipes-extended
parente7e2e3cf814cc3688abc9cd026f799b2bd3ea061 (diff)
downloadmeta-openembedded-contrib-eb18c5dfa9fd736c454d65301e8512a1b043738f.tar.gz
zlog: Add recipe
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/zlog/zlog_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/zlog/zlog_git.bb b/meta-oe/recipes-extended/zlog/zlog_git.bb
new file mode 100644
index 0000000000..51c746fd32
--- /dev/null
+++ b/meta-oe/recipes-extended/zlog/zlog_git.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Zlog is a pure C logging library"
+HOMEPAGE = "https://github.com/HardySimpson/zlog"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+PV = "1.2.12+git${SRCPV}"
+
+SRCREV = "13904dab2878aa2654d0c20fb8600a3dc5f2dd68"
+SRC_URI = "git://github.com/HardySimpson/zlog"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "CC='${CC}' LD='${LD}'"
+
+do_install() {
+ oe_runmake install PREFIX=${D}${exec_prefix} INSTALL=install
+}