aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-01 23:50:14 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-12 06:56:44 +0200
commite7bd0b99108a9688f991dfcd74cca36fd9c5dc95 (patch)
tree37f46af78785fe966c02e5e1b6efa48454ca14e0 /meta-oe/recipes-extended
parent5a32f8fcc1d1143db44ffed9e6d1085c825780ac (diff)
downloadmeta-openembedded-contrib-e7bd0b99108a9688f991dfcd74cca36fd9c5dc95.tar.gz
leveldb: Update to 1.20
package tests into a seprate package package static libs as well Update also fixes build with musl Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/leveldb/leveldb/0001-Explicitly-disable-tcmalloc.patch48
-rw-r--r--meta-oe/recipes-extended/leveldb/leveldb_git.bb19
2 files changed, 13 insertions, 54 deletions
diff --git a/meta-oe/recipes-extended/leveldb/leveldb/0001-Explicitly-disable-tcmalloc.patch b/meta-oe/recipes-extended/leveldb/leveldb/0001-Explicitly-disable-tcmalloc.patch
deleted file mode 100644
index 4b76dd0c31..0000000000
--- a/meta-oe/recipes-extended/leveldb/leveldb/0001-Explicitly-disable-tcmalloc.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From d6daac04dab4b3acf4b88f16742d1b402cdc3d83 Mon Sep 17 00:00:00 2001
-From: Martin Jansa <Martin.Jansa@gmail.com>
-Date: Wed, 1 Oct 2014 18:54:04 +0200
-Subject: [PATCH] Explicitly disable tcmalloc
-
-Without this change leveldb autodetects tcmalloc from sysroot and
-sometimes became dependant on gperftools
-
-Disable autodetection without TCMALLOC_ENABLED=true pased to make
-
-Upstream-Status: Pending
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- build_detect_platform | 16 +++++++++-------
- 1 file changed, 9 insertions(+), 7 deletions(-)
-
-diff --git a/build_detect_platform b/build_detect_platform
-index bb76c4f..a586364 100755
---- a/build_detect_platform
-+++ b/build_detect_platform
-@@ -201,15 +201,17 @@ EOF
- PLATFORM_LIBS="$PLATFORM_LIBS -lsnappy"
- fi
-
-- # Test whether tcmalloc is available
-- $CXX $CXXFLAGS -x c++ - -o $CXXOUTPUT -ltcmalloc 2>/dev/null <<EOF
-- int main() {}
-+ if [ "$TCMALLOC_ENABLED" = "true" ]; then
-+ # Test whether tcmalloc is available
-+ $CXX $CXXFLAGS -x c++ - -o $CXXOUTPUT -ltcmalloc 2>/dev/null <<EOF
-+ int main() {}
- EOF
-- if [ "$?" = 0 ]; then
-- PLATFORM_LIBS="$PLATFORM_LIBS -ltcmalloc"
-- fi
-+ if [ "$?" = 0 ]; then
-+ PLATFORM_LIBS="$PLATFORM_LIBS -ltcmalloc"
-+ fi
-
-- rm -f $CXXOUTPUT 2>/dev/null
-+ rm -f $CXXOUTPUT 2>/dev/null
-+ fi
- fi
-
- PLATFORM_CCFLAGS="$PLATFORM_CCFLAGS $COMMON_FLAGS"
---
-2.1.1
-
diff --git a/meta-oe/recipes-extended/leveldb/leveldb_git.bb b/meta-oe/recipes-extended/leveldb/leveldb_git.bb
index a6a3024301..d44aa14d28 100644
--- a/meta-oe/recipes-extended/leveldb/leveldb_git.bb
+++ b/meta-oe/recipes-extended/leveldb/leveldb_git.bb
@@ -4,15 +4,16 @@ HOMEPAGE = "http://leveldb.googlecode.com"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=92d1b128950b11ba8495b64938fc164d"
-SRCREV = "803d69203a62faf50f1b77897310a3a1fcae712b"
-PV = "1.18+git${SRCPV}"
+SRCREV = "a53934a3ae1244679f812d998a4f16f2c7f309a6"
+PV = "1.20+git${SRCPV}"
SRC_URI = "git://github.com/google/${BPN}.git \
- file://0001-Explicitly-disable-tcmalloc.patch \
"
S = "${WORKDIR}/git"
+inherit utils
+
do_compile() {
# do not use oe_runmake. oe_runmake pass to make compilation arguments and override
# leveldb makefile variable CFLAGS and broke leveldb build.
@@ -20,8 +21,14 @@ do_compile() {
}
do_install() {
- install -d ${D}${libdir}
- oe_libinstall -C ${S} -so libleveldb ${D}${libdir}
- install -d ${D}${includedir}/leveldb
+ install -d ${D}${libdir} ${D}${bindir} ${D}${includedir}/leveldb
+ oe_libinstall -C ${B}/out-shared libleveldb ${D}${libdir}
+ oe_libinstall -C ${S}/out-static libleveldb ${D}${libdir}
+ oe_libinstall -C ${S}/out-static libmemenv ${D}${libdir}
+ install -m 0755 ${B}/out-shared/db_bench ${D}${bindir}
+ install -m 0755 ${B}/out-static/*_test ${D}${bindir}
install -m 644 ${S}/include/leveldb/*.h ${D}${includedir}/leveldb/
}
+
+PACKAGES =+ "${PN}-ptest"
+FILES_${PN}-ptest = "${bindir}"