aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2017-04-05 19:35:16 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-05 19:36:45 +0200
commitcdb428e7c49899675ee7b7a43f6cecdb5b4c2546 (patch)
tree42c4f0752df5a0bae2c3aeec8362faa029adc792 /meta-oe/recipes-extended
parent2af18f934cd6764ef87977c8b23a924a5cb7fbf7 (diff)
downloadmeta-openembedded-contrib-cdb428e7c49899675ee7b7a43f6cecdb5b4c2546.tar.gz
recipes: add removal date to PNBLACKLIST messages
* based on discussion in pndeprecated thread: https://patchwork.openembedded.org/patch/137573/ update the messages to warn possible users that the recipe will be removed before the end of the next development cycle (before Yocto 2.4 is released). * updated with: sed -i 's/^\(PNBLACKLIST.*".*\)"/\1 - the recipe will be removed on 2017-09-01 unless the issue is fixed"/g' `git grep PNBLACKLIST | sed 's/:.*//g' | sort -u | xargs` * then noticed couple recipes being blacklisted only based on DISTRO_FEATURES, so removed those: meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.17.bb meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.5.bb meta-oe/recipes-connectivity/bluez/bluez4_4.101.bb meta-oe/recipes-connectivity/bluez/gst-plugin-bluetooth_4.101.bb meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb meta-oe/recipes-navigation/gypsy/gypsy.inc meta-oe/recipes-navigation/navit/navit.inc meta-oe/recipes-support/opensync/libsyncml_0.5.4.bb * if it isn't fixed by this date, it's fair game to be removed whenever someone gets around to i Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/openlmi/openlmi-networking_0.3.1.bb2
-rw-r--r--meta-oe/recipes-extended/openlmi/openlmi-providers_0.6.0.bb2
-rw-r--r--meta-oe/recipes-extended/openlmi/openlmi-storage_0.8.1.bb2
-rw-r--r--meta-oe/recipes-extended/subsurface/subsurface_git.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-extended/openlmi/openlmi-networking_0.3.1.bb b/meta-oe/recipes-extended/openlmi/openlmi-networking_0.3.1.bb
index a7ce508ea2..081bd3bc00 100644
--- a/meta-oe/recipes-extended/openlmi/openlmi-networking_0.3.1.bb
+++ b/meta-oe/recipes-extended/openlmi/openlmi-networking_0.3.1.bb
@@ -29,4 +29,4 @@ do_configure_prepend() {
FILES_${PN} =+ "${libdir}/cmpi/libcmpiLMI_Networking.so ${prefix}/libexec*"
FILES_${PN}-dbg =+ "${libdir}/cmpi/.debug*"
-PNBLACKLIST[openlmi-networking] ?= "Depends on blacklisted openlmi-providers"
+PNBLACKLIST[openlmi-networking] ?= "Depends on blacklisted openlmi-providers - the recipe will be removed on 2017-09-01 unless the issue is fixed"
diff --git a/meta-oe/recipes-extended/openlmi/openlmi-providers_0.6.0.bb b/meta-oe/recipes-extended/openlmi/openlmi-providers_0.6.0.bb
index d4f8c46e7e..2eda65320d 100644
--- a/meta-oe/recipes-extended/openlmi/openlmi-providers_0.6.0.bb
+++ b/meta-oe/recipes-extended/openlmi/openlmi-providers_0.6.0.bb
@@ -53,4 +53,4 @@ FILES_${PN}-dbg =+ "${libdir}/cmpi/.debug*"
RDEPENDS_${PN} = "python"
-PNBLACKLIST[openlmi-providers] ?= "Depends on blacklisted lmsensors"
+PNBLACKLIST[openlmi-providers] ?= "Depends on blacklisted lmsensors - the recipe will be removed on 2017-09-01 unless the issue is fixed"
diff --git a/meta-oe/recipes-extended/openlmi/openlmi-storage_0.8.1.bb b/meta-oe/recipes-extended/openlmi/openlmi-storage_0.8.1.bb
index 5facde6d7a..f99b77ca41 100644
--- a/meta-oe/recipes-extended/openlmi/openlmi-storage_0.8.1.bb
+++ b/meta-oe/recipes-extended/openlmi/openlmi-storage_0.8.1.bb
@@ -31,4 +31,4 @@ do_install_append() {
FILES_${PN} =+ "${sysconfdir}/openlmi/storage/storage.conf ${datadir}/${BPN}/*"
-PNBLACKLIST[openlmi-storage] ?= "Depends on blacklisted pywbem"
+PNBLACKLIST[openlmi-storage] ?= "Depends on blacklisted pywbem - the recipe will be removed on 2017-09-01 unless the issue is fixed"
diff --git a/meta-oe/recipes-extended/subsurface/subsurface_git.bb b/meta-oe/recipes-extended/subsurface/subsurface_git.bb
index 22b9d2fd70..90adaf4876 100644
--- a/meta-oe/recipes-extended/subsurface/subsurface_git.bb
+++ b/meta-oe/recipes-extended/subsurface/subsurface_git.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "libdivecomputer gtk+ libxml2 glib-2.0 gconf"
-PNBLACKLIST[subsurface] ?= "Needs to be upgraded for compatibility with new libdivecomputer"
+PNBLACKLIST[subsurface] ?= "Needs to be upgraded for compatibility with new libdivecomputer - the recipe will be removed on 2017-09-01 unless the issue is fixed"
inherit gtk-icon-cache cmake