aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/zram/zram_0.1.bb
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2012-09-18 15:31:17 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-09-24 10:01:47 +0200
commitd6055c8e443c0808d7eada9cda8c159da3e095fb (patch)
tree901a2c0980d4edd264963b7e79122f9b09a6ffbb /meta-oe/recipes-extended/zram/zram_0.1.bb
parent4cfe58d3ce694ee2951a0ed0e855c6e4dbca2dc2 (diff)
downloadmeta-openembedded-contrib-d6055c8e443c0808d7eada9cda8c159da3e095fb.tar.gz
zram: Integrate an init script
Signed-off-by: Andrei Gherzan <andrei@gherzan.ro> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-extended/zram/zram_0.1.bb')
-rw-r--r--meta-oe/recipes-extended/zram/zram_0.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/zram/zram_0.1.bb b/meta-oe/recipes-extended/zram/zram_0.1.bb
new file mode 100644
index 0000000000..85262647c0
--- /dev/null
+++ b/meta-oe/recipes-extended/zram/zram_0.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Linux zram compressed in-memory swap"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
+inherit allarch update-rc.d
+
+RDEPENDS_${PN} = "util-linux-swaponoff kmod kernel-module-zram"
+
+PR = "r0"
+
+SRC_URI = " \
+ file://init \
+ "
+
+do_install () {
+ # Sysvinit
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/zram
+}
+
+FILES_${PN} = "${sysconfdir}/init.d"
+INITSCRIPT_NAME = "zram"
+INITSCRIPT_PARAMS = "start 05 2 3 4 5 . stop 22 0 1 6 ."