aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/wipe/files
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2016-08-18 17:37:40 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-22 15:49:29 +0200
commitc4ea81241b0dd760a479c4a5edfa0e39d93fcff2 (patch)
tree412759647b36bd2e6c21f6948941de1e9c0001b3 /meta-oe/recipes-extended/wipe/files
parent7fdf3535f6b60f3ea268b718728a007140f0657a (diff)
downloadmeta-openembedded-contrib-c4ea81241b0dd760a479c4a5edfa0e39d93fcff2.tar.gz
wipe: fix QA warning for GNU_HASH
Add LDFLAGS variable to Makefile so that extra linker flags can be sent via this variable. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/wipe/files')
-rw-r--r--meta-oe/recipes-extended/wipe/files/makefile-add-ldflags.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/wipe/files/makefile-add-ldflags.patch b/meta-oe/recipes-extended/wipe/files/makefile-add-ldflags.patch
new file mode 100644
index 0000000000..fac1b31dcc
--- /dev/null
+++ b/meta-oe/recipes-extended/wipe/files/makefile-add-ldflags.patch
@@ -0,0 +1,17 @@
+Upstream-Status: Pending
+
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+
+diff --git a/Makefile b/Makefile
+index 9e74cdf..cad8109 100644
+--- a/Makefile
++++ b/Makefile
+@@ -151,7 +151,7 @@ generic :
+ $(MAKE) $(TARGETS) "CC=$(CC_GENERIC)" "CCO=$(CCO_GENERIC)" "CCOC=$(CCOC_GENERIC)"
+
+ wipe : $(OBJECTS)
+- $(CC) $(CCO) $(OBJECTS) -o wipe
++ $(CC) $(CCO) $(LDFLAGS) $(OBJECTS) -o wipe
+
+ wipe.o : wipe.c random.h misc.h version.h
+ $(CC) $(CCO) $(CCOC) wipe.c -o wipe.o