aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/upm
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-10-24 00:41:39 -0700
committerKhem Raj <raj.khem@gmail.com>2019-10-25 10:29:50 -0700
commita802d88464329cc52ad3df1db7d6fe492b372db6 (patch)
treeb5669bf169e16e65f28ee3291fc41e814dfea7cf /meta-oe/recipes-extended/upm
parent6bf265130aca34eded5e0a37bfc24bba7b9d1339 (diff)
downloadmeta-openembedded-contrib-a802d88464329cc52ad3df1db7d6fe492b372db6.tar.gz
upm: Define PYTHON_INCLUDE_DIR and PYTHON_LIBRARY for cmake
Otherwise it peeks into native sysroot now and starts using native python which is undesirable, this is happening after the oe-core change https://git.openembedded.org/openembedded-core/commit/?id=7847f431cd8db59fce8c9401a603c4b0678ee16d Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/upm')
-rw-r--r--meta-oe/recipes-extended/upm/upm_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/upm/upm_git.bb b/meta-oe/recipes-extended/upm/upm_git.bb
index a6b379ec36..fb22e83359 100644
--- a/meta-oe/recipes-extended/upm/upm_git.bb
+++ b/meta-oe/recipes-extended/upm/upm_git.bb
@@ -36,7 +36,7 @@ BINDINGS_armv5 ??= "python"
PACKAGECONFIG ??= "${@bb.utils.contains('PACKAGES', 'node-${PN}', 'nodejs', '', d)} \
${@bb.utils.contains('PACKAGES', '${PYTHON_PN}-${PN}', 'python', '', d)}"
-PACKAGECONFIG[python] = "-DBUILDSWIGPYTHON=ON, -DBUILDSWIGPYTHON=OFF, swig-native ${PYTHON_PN},"
+PACKAGECONFIG[python] = "-DBUILDSWIGPYTHON=ON -DPYTHON_LIBRARY=${STAGING_LIBDIR}/lib${PYTHON_DIR}${PYTHON_ABI}.so -DPYTHON_INCLUDE_DIR=${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}, -DBUILDSWIGPYTHON=OFF, swig-native ${PYTHON_PN},"
PACKAGECONFIG[nodejs] = "-DBUILDSWIGNODE=ON, -DBUILDSWIGNODE=OFF, swig-native nodejs-native,"
FILES_${PYTHON_PN}-${PN} = "${PYTHON_SITEPACKAGES_DIR}"