aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/upm/upm_git.bb
diff options
context:
space:
mode:
authorMikko Ylinen <mikko.ylinen@linux.intel.com>2017-10-27 16:35:46 +0300
committerArmin Kuster <akuster808@gmail.com>2017-11-15 16:34:05 -0800
commit2913f7073f39a216ba215868f2d7e18a1ed05a2c (patch)
tree80caa8d9fb89712dcab44d1d51602d60b614546e /meta-oe/recipes-extended/upm/upm_git.bb
parent5fbf909b0f155d843c27be2313d2390b66251409 (diff)
downloadmeta-openembedded-contrib-2913f7073f39a216ba215868f2d7e18a1ed05a2c.tar.gz
mraa/upm: drop HAVE_NODEJS conditional
HAVE_NODEJS is a leftover from meta-refkit-core where the layer had to adapt to different BBLAYER combinations (some where nodejs wasn't available but mraa/upm were). mraa/upm nodejs bindings currently fail to build (due to a problem in swig with nodejs > v7.x) so we keep them disabled until a newer version of swig lands in OE-core. The commit adds BINDINGS overrides for armv4/5 to remind that nodejs isn't available on those architectures. Signed-off-by: Mikko Ylinen <mikko.ylinen@linux.intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/upm/upm_git.bb')
-rw-r--r--meta-oe/recipes-extended/upm/upm_git.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/upm/upm_git.bb b/meta-oe/recipes-extended/upm/upm_git.bb
index 38065ce534..a5c2bb3211 100644
--- a/meta-oe/recipes-extended/upm/upm_git.bb
+++ b/meta-oe/recipes-extended/upm/upm_git.bb
@@ -26,7 +26,13 @@ inherit distutils3-base cmake
# override this in local.conf to get needed bindings.
# BINDINGS_pn-upm="python"
# will result in only the python bindings being built/packaged.
-BINDINGS ??= "python ${@ 'nodejs' if oe.types.boolean(d.getVar('HAVE_NODEJS') or '0') else '' }"
+# Note: 'nodejs' is disabled by default because the bindings
+# generation currently fails with nodejs (>v7.x).
+BINDINGS ??= "python"
+
+# nodejs isn't available for armv4/armv5 architectures
+BINDINGS_armv4 ??= "python"
+BINDINGS_armv5 ??= "python"
PACKAGECONFIG ??= "${@bb.utils.contains('PACKAGES', 'node-${PN}', 'nodejs', '', d)} \
${@bb.utils.contains('PACKAGES', '${PYTHON_PN}-${PN}', 'python', '', d)}"