aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/sedutil
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-17 17:42:14 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-17 17:52:09 -0700
commit302a6c447456113255a4ec705aa4a17f404beb58 (patch)
tree4fff7ca162320b58b1dbde34bef199cb8aacb0a7 /meta-oe/recipes-extended/sedutil
parent6c25c473379a56729d8a4fa65c0ff646e2c8db29 (diff)
downloadmeta-openembedded-contrib-302a6c447456113255a4ec705aa4a17f404beb58.tar.gz
sedutils: Fix build with clang11
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/sedutil')
-rw-r--r--meta-oe/recipes-extended/sedutil/files/0001-DtaAnnotatedDump-Add-typedef-name-to-the-union.patch34
-rw-r--r--meta-oe/recipes-extended/sedutil/sedutil_git.bb1
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/sedutil/files/0001-DtaAnnotatedDump-Add-typedef-name-to-the-union.patch b/meta-oe/recipes-extended/sedutil/files/0001-DtaAnnotatedDump-Add-typedef-name-to-the-union.patch
new file mode 100644
index 0000000000..4be3353c66
--- /dev/null
+++ b/meta-oe/recipes-extended/sedutil/files/0001-DtaAnnotatedDump-Add-typedef-name-to-the-union.patch
@@ -0,0 +1,34 @@
+From 9db49b94336f65453e06fb6a6bc4e6edf9403fea Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 17 Aug 2020 17:22:09 -0700
+Subject: [PATCH] DtaAnnotatedDump: Add typedef name to the union
+
+This is found with clang
+error: anonymous non-C-compatible type given name for linkage purposes by
+typedef declaration; add a tag name here [-Werror,-Wnon-c-typedef-for-linkage]
+| typedef union
+| ^
+| CAtomHeader
+
+Upstream-Status: Submitted [https://github.com/Drive-Trust-Alliance/sedutil/pull/332]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Common/DtaAnnotatedDump.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Common/DtaAnnotatedDump.h b/Common/DtaAnnotatedDump.h
+index 2749365..734c8eb 100644
+--- a/Common/DtaAnnotatedDump.h
++++ b/Common/DtaAnnotatedDump.h
+@@ -20,7 +20,7 @@ along with sedutil. If not, see <http://www.gnu.org/licenses/>.
+
+ #pragma pack(push,1)
+
+-typedef union
++typedef union CAtomHeader_t
+ {
+ // four bytes in big endian (network) byte order
+ uint8_t all[4];
+--
+2.28.0
+
diff --git a/meta-oe/recipes-extended/sedutil/sedutil_git.bb b/meta-oe/recipes-extended/sedutil/sedutil_git.bb
index 765618433b..1e7a393193 100644
--- a/meta-oe/recipes-extended/sedutil/sedutil_git.bb
+++ b/meta-oe/recipes-extended/sedutil/sedutil_git.bb
@@ -12,6 +12,7 @@ PV = "${BASEPV}+git${SRCPV}"
SRCREV = "358cc758948be788284d5faba46ccf4cc1813796"
SRC_URI = "git://github.com/Drive-Trust-Alliance/sedutil.git \
file://0001-Fix-build-on-big-endian-architectures.patch \
+ file://0001-DtaAnnotatedDump-Add-typedef-name-to-the-union.patch \
"
S = "${WORKDIR}/git"