aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-09-10 20:40:10 -0700
committerArmin Kuster <akuster808@gmail.com>2019-10-05 07:45:32 -0700
commitb3a244153414fa627b247dd29f95197fdaae69e1 (patch)
treeb2bcbd15ceb0eb21785993cb003a09f0b3c283dc /meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch
parent6a98afe854907a6263ab5f08ccbc155943470c59 (diff)
downloadmeta-openembedded-contrib-b3a244153414fa627b247dd29f95197fdaae69e1.tar.gz
redis: Fix build with clang/x86
Need to link with libatomics for 64bit atomics support Fixes i686-yoe-linux/i686-yoe-linux-ld: networking.o: in function `createClient': | /usr/src/debug/redis/4.0.14-r0/redis-4.0.14/src/networking.c:103: undefined reference to `__atomic_fetch_add_8' Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 2b49254d61ca817799a206cd022617854aa5bc0b) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch')
-rw-r--r--meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch b/meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch
new file mode 100644
index 0000000000..04af15dd86
--- /dev/null
+++ b/meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch
@@ -0,0 +1,32 @@
+From 97584e1eb78dc18599534b47b6670c20c63f5ee2 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 10 Sep 2019 20:04:26 -0700
+Subject: [PATCH] src: Do not reset FINAL_LIBS
+
+This helps case where additional libraries are needed to be passed from
+environment to get it going
+
+e.g. -latomic is needed on clang/x86 to provide for 64bit atomics
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index 7f7c625..c71dd3b 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -66,7 +66,7 @@ endif
+
+ FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS)
+ FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
+-FINAL_LIBS=-lm
++FINAL_LIBS+=-lm
+ DEBUG=-g -ggdb
+
+ ifeq ($(uname_S),SunOS)
+--
+2.23.0
+