aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@siemens.com>2016-09-02 11:01:00 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-11 09:11:22 +0200
commit8f6a4859751ed3d6610cc03348da292ed8ef2cf0 (patch)
tree1f46c5d7834c67e7d130eab15dcbaa292811f9dc /meta-oe/recipes-extended/p7zip/p7zip_16.02.bb
parent0a5c689b6823bbad0b535c98841f0f85b23db90f (diff)
downloadmeta-openembedded-contrib-8f6a4859751ed3d6610cc03348da292ed8ef2cf0.tar.gz
p7zip: update to version 16.02
Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/p7zip/p7zip_16.02.bb')
-rw-r--r--meta-oe/recipes-extended/p7zip/p7zip_16.02.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb b/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb
new file mode 100644
index 0000000000..12be02cafe
--- /dev/null
+++ b/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb
@@ -0,0 +1,37 @@
+SUMMARY = "7-zip is a commandline utility handling 7z archives."
+HOMEPAGE = "http://www.7-zip.org/"
+LICENSE = "LGPL-2.1+ & unRAR"
+LIC_FILES_CHKSUM = "file://DOC/copying.txt;md5=4fbd65380cdd255951079008b364516c \
+ file://DOC/unRarLicense.txt;md5=9c87ddde469ef94aed153b0951d088de \
+ file://DOC/License.txt;md5=8346bfd0a2fa0987e7a3a512adf84ab9"
+
+SRC_URI = "http://downloads.sourceforge.net/p7zip/p7zip/${PV}/p7zip_${PV}_src_all.tar.bz2 \
+ file://do_not_override_compiler_and_do_not_strip.patch"
+
+SRC_URI[md5sum] = "a0128d661cfe7cc8c121e73519c54fbf"
+SRC_URI[sha256sum] = "5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6e2341f"
+
+S = "${WORKDIR}/${BPN}_${PV}"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/bin/* ${D}${bindir}
+}
+
+# all3: to build bin/7za, bin/7z (with its plugins), bin/7zr and bin/7zCon.sfx
+EXTRA_OEMAKE_class-native = "all3"
+
+do_install_class-native() {
+ install -d ${D}${bindir}
+ install -d ${D}${bindir}/Codecs
+ install -m 0755 ${S}/bin/7* ${D}${bindir}
+ install -m 0755 ${S}/bin/Codecs/* ${D}${bindir}/Codecs
+
+ # Create a shell script wrapper to execute next to 7z.so
+ mv ${D}${bindir}/7z ${D}${bindir}/7z.bin
+ echo "#! /bin/sh" > ${D}${bindir}/7z
+ echo "exec ${D}${bindir}/7z.bin \"\$@\"" >> ${D}${bindir}/7z
+ chmod 0755 ${D}${bindir}/7z
+}
+
+BBCLASSEXTEND += "native"