aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/mozjs/mozjs_52.8.1.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-07-17 09:31:44 +0800
committerKhem Raj <raj.khem@gmail.com>2018-07-16 18:42:40 -0700
commit50e8ed5fd4d09be1e89fb7fd0ba6b26c8be15699 (patch)
tree355eb7bc6cce190180b8cef5245ebcc7b73b81e5 /meta-oe/recipes-extended/mozjs/mozjs_52.8.1.bb
parent2de6f8d1b4608dbdce391c3d89d01402eb641f52 (diff)
downloadmeta-openembedded-contrib-50e8ed5fd4d09be1e89fb7fd0ba6b26c8be15699.tar.gz
mozjs: 17.0.0 -> 52.8.1
- Refactor recipe 52.8.1 0001 ~ 0006 - Rebase patches to 52.8.1; 0001-js.pc.in-do-not-include-RequiredDefines.h-for-depend.patch 0010-fix-cross-compilation-on-i586-targets.patch' - Drop 0001-regenerate-configure.patch and everything works well - Drop Manually_mmap_heap_memory_esr17.patch which is backported - Drop obsolete patches 0001-compare-the-first-character-of-string-to-be-null-or-.patch 0001-mozjs17.0.0-fix-the-compile-bug-of-powerpc.patch 0002-Move-JS_BYTES_PER_WORD-out-of-config.h.patch 0004-mozbug746112-no-decommit-on-large-pages.patch 0005-aarch64-64k-page.patch fix_milestone_compile_issue.patch fix-the-compile-error-of-powerpc64.patch Update-Double-Conversion.patch and Update-the-double-conversion-update-script.patch - Set DISABLE_STATIC = "" to build without option `--disable-static' - Set musl patch (0006-support-musl.patch) with musl override. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/mozjs/mozjs_52.8.1.bb')
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs_52.8.1.bb95
1 files changed, 95 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_52.8.1.bb b/meta-oe/recipes-extended/mozjs/mozjs_52.8.1.bb
new file mode 100644
index 0000000000..7909602825
--- /dev/null
+++ b/meta-oe/recipes-extended/mozjs/mozjs_52.8.1.bb
@@ -0,0 +1,95 @@
+SUMMARY = "SpiderMonkey is Mozilla's JavaScript engine written in C/C++"
+HOMEPAGE = "https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=815ca599c9df247a0c7f619bab123dad"
+
+SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/main/m/mozjs52/mozjs52_52.8.1.orig.tar.bz2 \
+ file://0001-js.pc.in-do-not-include-RequiredDefines.h-for-depend.patch \
+ file://0010-fix-cross-compilation-on-i586-targets.patch \
+ file://0001-do-not-create-python-environment.patch \
+ file://0002-fix-cannot-find-link.patch \
+ file://0003-workaround-autoconf-2.13-detection-failed.patch \
+ file://0004-do-not-use-autoconf-2.13-to-refresh-old.configure.patch \
+ file://0005-fix-do_compile-failed-on-mips.patch \
+ "
+SRC_URI_append_libc-musl = " \
+ file://0006-support-musl.patch \
+ "
+
+SRC_URI[md5sum] = "3a44c2fd3d7b5a370ed9184163c74bc4"
+SRC_URI[sha256sum] = "fb5e11b7f31a33be820d5c947c5fa114751b0d5033778c1cd8e0cf2dad91e8fa"
+
+inherit autotools pkgconfig perlnative pythonnative
+
+DEPENDS += "nspr zlib"
+
+# nspr's package-config is ignored so set libs manually
+EXTRA_OECONF = " \
+ --target=${TARGET_SYS} \
+ --host=${BUILD_SYS} \
+ --prefix=${prefix} \
+ --libdir=${libdir} \
+ --disable-tests \
+ --with-nspr-libs='-lplds4 -lplc4 -lnspr4' \
+"
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
+PACKAGECONFIG[x11] = "--x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},,virtual/libx11"
+
+EXTRA_OEMAKE_task-compile += "OS_LDFLAGS='-Wl,-latomic ${LDFLAGS}'"
+EXTRA_OEMAKE_task-install += "STATIC_LIBRARY_NAME=js_static"
+
+do_configure() {
+ export SHELL="/bin/sh"
+ ${S}/js/src/configure ${EXTRA_OECONF}
+}
+
+do_compile_prepend() {
+ export SHELL="/bin/sh"
+ export S
+ export PYTHONPATH
+ cd ${S}
+ for sub_dir in python testing/mozbase; do
+ for module_dir in `ls $sub_dir -1`;do
+ [ $module_dir = "virtualenv" ] && continue
+ if [ -d "${S}/$sub_dir/$module_dir" ];then
+ PYTHONPATH="$PYTHONPATH:${S}/$sub_dir/$module_dir"
+ fi
+ done
+ done
+ PYTHONPATH="$PYTHONPATH:${S}/config:${S}/build"
+ cd -
+}
+
+do_install_prepend() {
+ export SHELL="/bin/sh"
+ export S
+ export PYTHONPATH
+ cd ${S}
+ for sub_dir in python testing/mozbase; do
+ for module_dir in `ls $sub_dir -1`;do
+ [ $module_dir = "virtualenv" ] && continue
+ if [ -d "${S}/$sub_dir/$module_dir" ];then
+ PYTHONPATH="$PYTHONPATH:${S}/$sub_dir/$module_dir"
+ fi
+ done
+ done
+ PYTHONPATH="$PYTHONPATH:${S}/config:${S}/build"
+ cd -
+}
+
+PACKAGES =+ "lib${BPN}"
+FILES_lib${BPN} += "${libdir}/lib*.so"
+FILES_${PN}-dev += "${bindir}/js52-config"
+
+# Fails to build with thumb-1 (qemuarm)
+#| {standard input}: Assembler messages:
+#| {standard input}:2172: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r2,r1,LSR#20'
+#| {standard input}:2173: Error: unshifted register required -- `bic r2,r2,#(1<<11)'
+#| {standard input}:2174: Error: unshifted register required -- `orr r1,r1,#(1<<20)'
+#| {standard input}:2176: Error: instruction not supported in Thumb16 mode -- `subs r2,r2,#0x300'
+#| {standard input}:2178: Error: instruction not supported in Thumb16 mode -- `subs r5,r2,#52'
+ARM_INSTRUCTION_SET_armv5 = "arm"
+ARM_INSTRUCTION_SET_armv4 = "arm"
+
+DISABLE_STATIC = ""