aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/libblockdev/libblockdev_2.16.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-03-23 23:50:54 +0100
committerArmin Kuster <akuster808@gmail.com>2018-04-08 17:00:06 -0700
commita79beac6dbd4012d3f82c6cfa761a2c6cdedba9e (patch)
treeb38f24b19c49d57e514efc31be2a3c30cd66e410 /meta-oe/recipes-extended/libblockdev/libblockdev_2.16.bb
parent3c468473ded31fe7e88b4da09477e60dceed9180 (diff)
downloadmeta-openembedded-contrib-a79beac6dbd4012d3f82c6cfa761a2c6cdedba9e.tar.gz
libblockdev: update 2.10 -> 2.16
I gave my best to rework patches: * 0005-fix-a-clang-compiling-issue.patch: This was a bit challenging. Because of I do not use clang I cannot test and confirm that no new breakers were introduced. * 0004-fix-compile-failure-against-musl-C-library.patch: Just tested to apply properly. Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/libblockdev/libblockdev_2.16.bb')
-rw-r--r--meta-oe/recipes-extended/libblockdev/libblockdev_2.16.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libblockdev/libblockdev_2.16.bb b/meta-oe/recipes-extended/libblockdev/libblockdev_2.16.bb
new file mode 100644
index 0000000000..0c954aa39b
--- /dev/null
+++ b/meta-oe/recipes-extended/libblockdev/libblockdev_2.16.bb
@@ -0,0 +1,51 @@
+DESCRIPTION = "libblockdev is a C library supporting GObject introspection for manipulation of \
+block devices. It has a plugin-based architecture where each technology (like \
+LVM, Btrfs, MD RAID, Swap,...) is implemented in a separate plugin, possibly \
+with multiple implementations (e.g. using LVM CLI or the new LVM DBus API)."
+HOMEPAGE = "http://rhinstaller.github.io/libblockdev/"
+LICENSE = "LGPLv2+"
+SECTION = "devel/lib"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
+
+inherit autotools python3native gobject-introspection
+
+DEPENDS += " \
+ cryptsetup \
+ nss \
+ volume-key \
+ libbytesize \
+ btrfs-tools \
+"
+
+SRCREV = "e2e0899efe8dd3f111ff955fb6c1dc10b0bd2075"
+SRC_URI = " \
+ git://github.com/rhinstaller/libblockdev;branch=master \
+ file://0001-fix-configure-and-compile-failures.patch \
+ file://0002-remove-python2-support.patch \
+ file://0003-remove-dmraid-while-compiling-with-with-dm.patch \
+ file://0005-fix-a-clang-compiling-issue.patch \
+"
+SRC_URI_append_libc-musl = " \
+ file://0004-fix-compile-failure-against-musl-C-library.patch \
+"
+
+S = "${WORKDIR}/git"
+
+RDEPENDS_${PN} += " \
+ lvm2 \
+"
+
+FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
+
+PACKAGECONFIG ??= "python3 lvm dm kmod parted fs"
+PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
+PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools"
+PACKAGECONFIG[dm] = "--with-dm, --without-dm"
+PACKAGECONFIG[kmod] = "--with-kbd, --without-kbd, kmod"
+PACKAGECONFIG[parted] = "--with-part, --without-part, parted"
+PACKAGECONFIG[fs] = "--with-fs, --without-fs, util-linux"
+PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
+
+export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs"
+