aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/lcdproc/lcdproc_0.5.6.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2015-01-03 01:37:33 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2015-01-05 10:56:33 +0000
commit75997a9d3f6e41037fe35f9a3c6efce0360dadbd (patch)
treefbe054d98843877d0c44b32abfac49673d9762cb /meta-oe/recipes-extended/lcdproc/lcdproc_0.5.6.bb
parenta0ff960271975254d1c2760e4af4d83996a6b388 (diff)
downloadmeta-openembedded-contrib-75997a9d3f6e41037fe35f9a3c6efce0360dadbd.tar.gz
lcdproc: update to 0.5.6
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-extended/lcdproc/lcdproc_0.5.6.bb')
-rw-r--r--meta-oe/recipes-extended/lcdproc/lcdproc_0.5.6.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/lcdproc/lcdproc_0.5.6.bb b/meta-oe/recipes-extended/lcdproc/lcdproc_0.5.6.bb
new file mode 100644
index 0000000000..4761ef7e9b
--- /dev/null
+++ b/meta-oe/recipes-extended/lcdproc/lcdproc_0.5.6.bb
@@ -0,0 +1,23 @@
+require lcdproc5.inc
+
+SRC_URI[md5sum] = "df4f5c2c7285eaf6979b9c7768b4877f"
+SRC_URI[sha256sum] = "bd2f43c30ff43b30f43110abe6b4a5bc8e0267cb9f57fa97cc5e5ef9488b984a"
+
+PACKAGECONFIG ?= ""
+PACKAGECONFIG[g15] = ",,libg15 g15daemon libg15render,"
+PACKAGECONFIG[hid] = "--enable-libhid,--disable-libhid,libhid"
+
+LCD_DRIVERS_append = "${@base_contains('PACKAGECONFIG', 'g15', '', ',!g15', d)}"
+
+do_install_append () {
+ # binaries
+ install -D -m 0755 clients/lcdvc/lcdvc ${D}${sbindir}/lcdvc
+
+ # configuration files
+ install -D -m 0644 ${S}/clients/lcdvc/lcdvc.conf ${D}${sysconfdir}/lcdvc.conf
+}
+
+PACKAGES =+ "lcdvc"
+CONFFILES_lcdvc = "${sysconfdir}/lcdvc.conf"
+FILES_lcdvc = "${sysconfdir}/lcdvc.conf ${sbindir}/lcdvc"
+