aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/hplip
diff options
context:
space:
mode:
authorDiego Rondini <diego.rondini@kynetics.com>2020-09-10 21:09:56 +0200
committerKhem Raj <raj.khem@gmail.com>2020-09-10 21:20:23 -0700
commitdb7fc115e058e2e0e481e284768538f097cfdd90 (patch)
tree0b5654ca40c08dcd25f7ff1424d7a20c150b13d9 /meta-oe/recipes-extended/hplip
parenta6b2a0c3d045bd09d4049ca8fb155f881657c31f (diff)
downloadmeta-openembedded-contrib-db7fc115e058e2e0e481e284768538f097cfdd90.tar.gz
hplip: use libexecdir
In oe-core commit: 2ce6ef29b9bb4f16ed9d78e166d455b7a6d968bf cups crossscripts have been fixed to report the correct serverbin folder, so backend, filters, etc, need to go in ${libexecdir} now. Signed-off-by: Diego Rondini <diego.rondini@kynetics.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/hplip')
-rw-r--r--meta-oe/recipes-extended/hplip/hplip_3.19.12.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta-oe/recipes-extended/hplip/hplip_3.19.12.bb b/meta-oe/recipes-extended/hplip/hplip_3.19.12.bb
index 883a6ffe95..457a974534 100644
--- a/meta-oe/recipes-extended/hplip/hplip_3.19.12.bb
+++ b/meta-oe/recipes-extended/hplip/hplip_3.19.12.bb
@@ -39,8 +39,8 @@ EXTRA_OECONF += "\
--enable-foomatic-drv-install \
--disable-foomatic-ppd-install \
--disable-foomatic-rip-hplip-install \
- --with-cupsbackenddir=${libdir}/cups/backend \
- --with-cupsfilterdir=${libdir}/cups/filter \
+ --with-cupsbackenddir=${libexecdir}/cups/backend \
+ --with-cupsfilterdir=${libexecdir}/cups/filter \
"
EXTRA_OEMAKE = "rulessystemdir=${systemd_unitdir}/system/"
@@ -52,7 +52,7 @@ do_install_append() {
sed -i -e "s|/usr/bin/python|/usr/bin/env python3|g" ${D}${datadir}/hplip/*.py
}
-PACKAGES += "${PN}-ppd ${PN}-cups ${PN}-backend ${PN}-filter ${PN}-hal"
+PACKAGE_BEFORE_PN += "${PN}-ppd ${PN}-cups ${PN}-backend ${PN}-filter ${PN}-hal"
RDEPENDS_${PN} += " \
python3\
@@ -70,15 +70,15 @@ RDEPENDS_${PN}-filter += "perl"
# need to snag the debug file or OE will fail on backend package
FILES_${PN}-dbg += "\
- ${libdir}/cups/backend/.debug \
+ ${libexecdir}/cups/backend/.debug \
${PYTHON_SITEPACKAGES_DIR}/.debug \
- ${libdir}/cups/filter/.debug "
+ ${libexecdir}/cups/filter/.debug "
FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/*.la"
FILES_${PN}-ppd = "${datadir}/ppd"
FILES_${PN}-cups = "${datadir}/cups"
-FILES_${PN}-backend = "${libdir}/cups/backend"
-FILES_${PN}-filter = "${libdir}/cups/filter"
+FILES_${PN}-backend = "${libexecdir}/cups/backend"
+FILES_${PN}-filter = "${libexecdir}/cups/filter"
FILES_${PN}-hal = "${datadir}/hal"
FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/*.so"