aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/gnuplot/gnuplot/lua-loadlibs-configure-in-fix.patch
diff options
context:
space:
mode:
authorQi.Chen@windriver.com <Qi.Chen@windriver.com>2016-11-07 18:05:02 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-23 15:24:42 +0100
commit2372fb641257a81547a20483bda4913f90605997 (patch)
tree32f85b96ab3e74342ecbabe6269c6cbe8187a992 /meta-oe/recipes-extended/gnuplot/gnuplot/lua-loadlibs-configure-in-fix.patch
parentb70dd8f2af20bdafcdcec0db4ad4fb5b4e688e35 (diff)
downloadmeta-openembedded-contrib-2372fb641257a81547a20483bda4913f90605997.tar.gz
gnuplot: upgrade to 5.0.5
Add PACKAGECONFIG for 'qt4' and default to not enable it as there's do_compile failure when qt4 is enabled. The obsolete '--without-lisp-files' option is removed. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/gnuplot/gnuplot/lua-loadlibs-configure-in-fix.patch')
-rw-r--r--meta-oe/recipes-extended/gnuplot/gnuplot/lua-loadlibs-configure-in-fix.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/gnuplot/gnuplot/lua-loadlibs-configure-in-fix.patch b/meta-oe/recipes-extended/gnuplot/gnuplot/lua-loadlibs-configure-in-fix.patch
new file mode 100644
index 0000000000..23f2cd26a5
--- /dev/null
+++ b/meta-oe/recipes-extended/gnuplot/gnuplot/lua-loadlibs-configure-in-fix.patch
@@ -0,0 +1,16 @@
+Index: gnuplot-4.6.5/configure.in
+===================================================================
+--- gnuplot-4.6.5.orig/configure.in
++++ gnuplot-4.6.5/configure.in
+@@ -690,6 +690,11 @@ if test "${with_lua}" = yes ; then
+ fi
+
+ if test "$with_lua" != no; then
++ dnl check for dlopen/dl to fix loadlibs link failure
++ AC_CHECK_FUNC([dlopen], [],
++ AC_CHECK_LIB([dl], [dlopen], DLOPEN_LIBS="-ldl"))
++ AC_SUBST(DLOPEN_LIBS)
++ LUA_LIBS="$LUA_LIBS $DLOPEN_LIBS"
+ TERMLIBS="$TERMLIBS $LUA_LIBS"
+ CPPFLAGS="$CPPFLAGS $LUA_CFLAGS"
+ else