aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/cfengine/cfengine-masterfiles_3.9.0.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2016-07-18 09:06:06 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-07-29 11:00:56 +0200
commit06e58b6f54b60585d1d6eb27b62c2627bce5f2fe (patch)
tree773afaaf14f055428677b9371b0dd4467be530f3 /meta-oe/recipes-extended/cfengine/cfengine-masterfiles_3.9.0.bb
parent898b3977afec283c456c970a48d654c74f128d61 (diff)
downloadmeta-openembedded-contrib-06e58b6f54b60585d1d6eb27b62c2627bce5f2fe.tar.gz
cfengine: add recipe and base policy
Add recipes of cfengine and cfengine-masterfiles which provides base policy files. There are 3 optional database backend: qdbm, tokyocabinet and lmdb with descending priority. Package tokyocabinet is released as a rework of qdbm by same upstream author, so it is choosen to be default database backend. See: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=452657 Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/cfengine/cfengine-masterfiles_3.9.0.bb')
-rw-r--r--meta-oe/recipes-extended/cfengine/cfengine-masterfiles_3.9.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/cfengine/cfengine-masterfiles_3.9.0.bb b/meta-oe/recipes-extended/cfengine/cfengine-masterfiles_3.9.0.bb
new file mode 100644
index 0000000000..9d01c51289
--- /dev/null
+++ b/meta-oe/recipes-extended/cfengine/cfengine-masterfiles_3.9.0.bb
@@ -0,0 +1,37 @@
+#
+# Copyright (C) 2014 - 2016 Wind River Systems, Inc.
+#
+SUMMARY = "Base policy for CFEngine"
+
+DESCRIPTION = "CFEngine is an IT infrastructure automation framework \
+that helps engineers, system administrators and other stakeholders \
+in an IT system to manage and understand IT infrastructure throughout \
+its lifecycle. CFEngine takes systems from Build to Deploy, Manage and Audit. \
+ \
+This package is intended to provide a stable base policy for \
+installations and upgrades, and is used by CFEngine 3.6 and newer. \
+ \
+The contents of this packge are intended to live in `/var/cfengine/masterfiles` \
+or wherever `$(sys.masterdir)` points. \
+"
+
+HOMEPAGE = "http://cfengine.com"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=52cd3d13af93180822888ab0088e9328"
+
+SRC_URI = "https://cfengine-package-repos.s3.amazonaws.com/tarballs/${BP}.tar.gz \
+ file://remove-policy-of-usr-local-sbin.patch \
+"
+SRC_URI[md5sum] = "b101ddcd546738af6ec91be5c297cb24"
+SRC_URI[sha256sum] = "63dec2f8649f5f2788cd463dccf47f8dbe941522acfcf3093517f983bbfa0606"
+
+inherit autotools
+
+export EXPLICIT_VERSION="${PV}"
+
+EXTRA_OECONF = "--prefix=${localstatedir}/cfengine"
+
+FILES_${PN} += "${localstatedir}/cfengine"
+
+RDEPENDS_${PN} += "python-core"