aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/boinc
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-oe/recipes-extended/boinc
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-contrib-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/boinc')
-rw-r--r--meta-oe/recipes-extended/boinc/boinc-client_7.16.16.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-oe/recipes-extended/boinc/boinc-client_7.16.16.bb b/meta-oe/recipes-extended/boinc/boinc-client_7.16.16.bb
index d2e81ee780..0acd099956 100644
--- a/meta-oe/recipes-extended/boinc/boinc-client_7.16.16.bb
+++ b/meta-oe/recipes-extended/boinc/boinc-client_7.16.16.bb
@@ -59,7 +59,7 @@ EXTRA_OECONF += "\
"
export PKG_CONFIG = "${STAGING_BINDIR_NATIVE}/pkg-config"
-do_configure_prepend () {
+do_configure:prepend () {
if [ "${@bb.utils.contains('DEPENDS', 'gtk+', '1', '0', d)}" = "0" ]
then
export GTK2_CFLAGS=""
@@ -67,14 +67,14 @@ do_configure_prepend () {
fi
}
-do_compile_prepend () {
+do_compile:prepend () {
# Disable rpaths
sed -i -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' ${B}/${TARGET_SYS}-libtool
sed -i -e 's|^sys_lib_dlsearch_path_spec=.*|sys_lib_dlsearch_path_spec=""|g' ${B}/${TARGET_SYS}-libtool
sed -i -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' ${B}/${TARGET_SYS}-libtool
}
-do_install_append() {
+do_install:append() {
if [ -e ${D}${nonarch_libdir}/systemd/system/boinc-client.service ]; then
install -d ${D}${systemd_system_unitdir}
mv \
@@ -86,6 +86,6 @@ do_install_append() {
fi
}
-SYSTEMD_SERVICE_${PN} = "boinc-client.service"
+SYSTEMD_SERVICE:${PN} = "boinc-client.service"
-FILES_${PN} += "${libdir}/systemd"
+FILES:${PN} += "${libdir}/systemd"