aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-03-15 09:16:21 -0700
committerKhem Raj <raj.khem@gmail.com>2022-03-16 08:32:19 -0700
commita8a9bc2bc908d2676902c0e29b2ae2af2f5078ec (patch)
treefab1abf8181e436694090c562f6404571846b6a6 /meta-oe/recipes-devtools
parent204391035949d80cf9010c4e8f69dc75b09cf911 (diff)
downloadmeta-openembedded-contrib-a8a9bc2bc908d2676902c0e29b2ae2af2f5078ec.tar.gz
abseil: Upgrade to 20211102.0 LTS release
Drop 0001-Export-of-internal-Abseil-changes.patch its already upstream forward port abseil-ppc-fixes.patch Changes in this release are absl::Cord is now implemented as a b-tree. The new implementation offers improved performance in most workloads. absl::SimpleHexAtoi() has been added to strings library for parsing hexadecimal strings. Details here [1] [1] https://github.com/abseil/abseil-cpp/releases/tag/20211102.0 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0001-Export-of-internal-Abseil-changes.patch87
-rw-r--r--meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/abseil-ppc-fixes.patch11
-rw-r--r--meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb7
3 files changed, 9 insertions, 96 deletions
diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0001-Export-of-internal-Abseil-changes.patch b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0001-Export-of-internal-Abseil-changes.patch
deleted file mode 100644
index 126b79261c..0000000000
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0001-Export-of-internal-Abseil-changes.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-From c9250af98f48e4aa734cab0e2f5ae1f780c05ad0 Mon Sep 17 00:00:00 2001
-From: Zang Ruochen <zangrc.fnst@fujitsu.com>
-Date: Fri, 11 Jun 2021 10:53:37 +0900
-Subject: [PATCH] Export of internal Abseil changes
-
---
-cf88f9cf40eab54c06bca7f20795352ec23bb583 by Derek Mauro <dmauro@google.com>:
-
-Fixes build with latest glibc
-Fixes #952
-
-PiperOrigin-RevId: 371693908
-
---
-99bcd0f4a747ce7a401e23c745adf34d0ec5131b by Samuel Benzaquen <sbenza@google.com>:
-
-Add support for std::string_view in StrFormat even when
-absl::string_view != std::string_view.
-
-PiperOrigin-RevId: 371693633
-
---
-e35463572149a6c2d4a0d439b9300ce03fd6b96d by Abseil Team <absl-team@google.com>:
-
-Cmake builds should only install pkg-config when explicitly requested.
-
-PiperOrigin-RevId: 371403419
-GitOrigin-RevId: cf88f9cf40eab54c06bca7f20795352ec23bb583
-Change-Id: I4360a18c638a4d901ff44ab1e0a9d8f321c302ea
-
-Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com>
----
- CMake/AbseilHelpers.cmake | 3 ++-
- absl/strings/internal/str_format/arg.h | 8 ++++++++
- absl/strings/internal/str_format/convert_test.cc | 3 +++
- 3 files changed, 13 insertions(+), 1 deletion(-)
-
-diff --git a/CMake/AbseilHelpers.cmake b/CMake/AbseilHelpers.cmake
-index 54fb8df3..a32b94d5 100644
---- a/CMake/AbseilHelpers.cmake
-+++ b/CMake/AbseilHelpers.cmake
-@@ -141,7 +141,8 @@ function(absl_cc_library)
- endif()
-
- # Generate a pkg-config file for every library:
-- if(_build_type STREQUAL "static" OR _build_type STREQUAL "shared")
-+ if((_build_type STREQUAL "static" OR _build_type STREQUAL "shared")
-+ AND ABSL_ENABLE_INSTALL)
- if(NOT ABSL_CC_LIB_TESTONLY)
- if(absl_VERSION)
- set(PC_VERSION "${absl_VERSION}")
-diff --git a/absl/strings/internal/str_format/arg.h b/absl/strings/internal/str_format/arg.h
-index 7040c866..3c91be70 100644
---- a/absl/strings/internal/str_format/arg.h
-+++ b/absl/strings/internal/str_format/arg.h
-@@ -122,6 +122,14 @@ StringConvertResult FormatConvertImpl(const std::string& v,
- StringConvertResult FormatConvertImpl(string_view v,
- FormatConversionSpecImpl conv,
- FormatSinkImpl* sink);
-+#if defined(ABSL_HAVE_STD_STRING_VIEW) && !defined(ABSL_USES_STD_STRING_VIEW)
-+inline StringConvertResult FormatConvertImpl(std::string_view v,
-+ FormatConversionSpecImpl conv,
-+ FormatSinkImpl* sink) {
-+ return FormatConvertImpl(absl::string_view(v.data(), v.size()), conv, sink);
-+}
-+#endif // ABSL_HAVE_STD_STRING_VIEW && !ABSL_USES_STD_STRING_VIEW
-+
- ArgConvertResult<FormatConversionCharSetUnion(
- FormatConversionCharSetInternal::s, FormatConversionCharSetInternal::p)>
- FormatConvertImpl(const char* v, const FormatConversionSpecImpl conv,
-diff --git a/absl/strings/internal/str_format/convert_test.cc b/absl/strings/internal/str_format/convert_test.cc
-index 926283cf..91e03609 100644
---- a/absl/strings/internal/str_format/convert_test.cc
-+++ b/absl/strings/internal/str_format/convert_test.cc
-@@ -229,6 +229,9 @@ TEST_F(FormatConvertTest, BasicString) {
- TestStringConvert(static_cast<const char*>("hello"));
- TestStringConvert(std::string("hello"));
- TestStringConvert(string_view("hello"));
-+#if defined(ABSL_HAVE_STD_STRING_VIEW)
-+ TestStringConvert(std::string_view("hello"));
-+#endif // ABSL_HAVE_STD_STRING_VIEW
- }
-
- TEST_F(FormatConvertTest, NullString) {
---
-2.25.1
-
diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/abseil-ppc-fixes.patch b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/abseil-ppc-fixes.patch
index a4937e1b33..e8048fe940 100644
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/abseil-ppc-fixes.patch
+++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/abseil-ppc-fixes.patch
@@ -31,13 +31,14 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
#ifdef __GLIBC__
--- a/absl/base/internal/unscaledcycleclock.h
+++ b/absl/base/internal/unscaledcycleclock.h
-@@ -46,7 +46,7 @@
+@@ -46,7 +46,8 @@
// The following platforms have an implementation of a hardware counter.
#if defined(__i386__) || defined(__x86_64__) || defined(__aarch64__) || \
-- defined(__powerpc__) || defined(__ppc__) || \
-+ ((defined(__powerpc__) || defined(__ppc__)) && defined(__GLIBC__)) || \
- defined(_M_IX86) || defined(_M_X64)
+- defined(__powerpc__) || defined(__ppc__) || defined(__riscv) || \
++ ((defined(__powerpc__) || defined(__ppc__)) && defined(__GLIBC__)) || \
++ defined(__riscv) || \
+ defined(_M_IX86) || defined(_M_X64)
#define ABSL_HAVE_UNSCALED_CYCLECLOCK_IMPLEMENTATION 1
#else
--- a/absl/debugging/internal/examine_stack.cc
@@ -67,7 +68,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
#elif defined(__s390__) && !defined(__s390x__)
--- a/absl/debugging/internal/stacktrace_config.h
+++ b/absl/debugging/internal/stacktrace_config.h
-@@ -55,7 +55,7 @@
+@@ -59,7 +59,7 @@
#elif defined(__i386__) || defined(__x86_64__)
#define ABSL_STACKTRACE_INL_HEADER \
"absl/debugging/internal/stacktrace_x86-inl.inc"
diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
index 37d5d81238..82124c1083 100644
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
+++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
@@ -7,14 +7,13 @@ SECTION = "libs"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=df52c6edb7adc22e533b2bacc3bd3915"
-PV = "20210324.2+git${SRCPV}"
-SRCREV = "278e0a071885a22dcd2fd1b5576cc44757299343"
-BRANCH = "lts_2021_03_24"
+PV = "20211102.0+git${SRCPV}"
+SRCREV = "215105818dfde3174fe799600bb0f3cae233d0bf"
+BRANCH = "lts_2021_11_02"
SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH};protocol=https \
file://0001-absl-always-use-asm-sgidefs.h.patch \
file://0002-Remove-maes-option-from-cross-compilation.patch \
file://abseil-ppc-fixes.patch \
- file://0001-Export-of-internal-Abseil-changes.patch \
"
S = "${WORKDIR}/git"