aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-05-29 00:46:02 -0700
committerKhem Raj <raj.khem@gmail.com>2021-05-31 07:48:02 -0700
commit949d9616cbf218934a2e3efb3da5ef0a544a338a (patch)
treed5664ad80363d86169047ea3683362f39b4cef4c /meta-oe/recipes-devtools
parente8262bab723b98ef094f680d49c8c0bcc136e0e9 (diff)
downloadmeta-openembedded-contrib-949d9616cbf218934a2e3efb3da5ef0a544a338a.tar.gz
grpc: Upgrade to 1.38.0
Fix build with musl by checking for iovec redefinition Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/grpc/grpc/0001-gsec-Fix-build-on-musl.patch37
-rw-r--r--meta-oe/recipes-devtools/grpc/grpc_1.38.0.bb (renamed from meta-oe/recipes-devtools/grpc/grpc_1.37.1.bb)4
2 files changed, 39 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/grpc/grpc/0001-gsec-Fix-build-on-musl.patch b/meta-oe/recipes-devtools/grpc/grpc/0001-gsec-Fix-build-on-musl.patch
new file mode 100644
index 0000000000..faa18bb7f7
--- /dev/null
+++ b/meta-oe/recipes-devtools/grpc/grpc/0001-gsec-Fix-build-on-musl.patch
@@ -0,0 +1,37 @@
+From 9af185be6068d279736c0d2b2162a4e768444d3d Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 29 May 2021 00:41:32 -0700
+Subject: [PATCH] gsec: Fix build on musl
+
+musl defines iovec struct in alltypes.h file which is included by many
+system include files, therefore check for appropriate define from musl
+before defining it again
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/core/tsi/alts/crypt/gsec.h | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/core/tsi/alts/crypt/gsec.h b/src/core/tsi/alts/crypt/gsec.h
+index 4d65caa944..3c367b2895 100644
+--- a/src/core/tsi/alts/crypt/gsec.h
++++ b/src/core/tsi/alts/crypt/gsec.h
+@@ -26,11 +26,14 @@
+ #include <stdlib.h>
+
+ #include <grpc/grpc.h>
++#include <sys/uio.h>
+
++#if !defined(__DEFINED_struct_iovec)
+ struct iovec {
+ void* iov_base;
+ size_t iov_len;
+ };
++#endif
+
+ /**
+ * A gsec interface for AEAD encryption schemes. The API is thread-compatible.
+--
+2.31.1
+
diff --git a/meta-oe/recipes-devtools/grpc/grpc_1.37.1.bb b/meta-oe/recipes-devtools/grpc/grpc_1.38.0.bb
index a7aabd13f0..2095d81d4a 100644
--- a/meta-oe/recipes-devtools/grpc/grpc_1.37.1.bb
+++ b/meta-oe/recipes-devtools/grpc/grpc_1.38.0.bb
@@ -16,8 +16,8 @@ RDEPENDS_${PN}-compiler = "${PN}"
RDEPENDS_${PN}-dev += "${PN}-compiler"
S = "${WORKDIR}/git"
-SRCREV_grpc = "8664c8334c05d322fbbdfb9e3b24601a23e9363c"
-BRANCH = "v1.37.x"
+SRCREV_grpc = "54dc182082db941aa67c7c3f93ad858c99a16d7d"
+BRANCH = "v1.38.x"
SRC_URI = "git://github.com/grpc/grpc.git;protocol=https;name=grpc;branch=${BRANCH} \
"
# Fixes build with older compilers 4.8 especially on ubuntu 14.04