aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorAngelo Ribeiro <Angelo.Ribeiro@criticaltechworks.com>2024-01-29 16:34:18 +0000
committerKhem Raj <raj.khem@gmail.com>2024-01-29 11:49:21 -0800
commit5683a9c54ac0cf20d0f1506769742572926b1d11 (patch)
tree2b45f4fbd7e16bf96ade719b9ab29b593a093dad /meta-oe/recipes-devtools
parentca7dccfce81b12466fe6858d34aa8a8bc2c0363c (diff)
downloadmeta-openembedded-contrib-5683a9c54ac0cf20d0f1506769742572926b1d11.tar.gz
flatcc: Add tool recipe
Add FlatCC FlatBuffers in C for C. FlatCC is a compiler that generates FlatBuffers code for C given a FlatBuffer schema file. Signed-off-by: Angelo Ribeiro <Angelo.Ribeiro@criticaltechworks.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/flatcc/flatcc_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/flatcc/flatcc_git.bb b/meta-oe/recipes-devtools/flatcc/flatcc_git.bb
new file mode 100644
index 0000000000..660a44c5a5
--- /dev/null
+++ b/meta-oe/recipes-devtools/flatcc/flatcc_git.bb
@@ -0,0 +1,27 @@
+SUMMARY = "FlatCC FlatBuffers in C for C"
+DESCRIPTION = "FlatCC is a compiler that generates FlatBuffers code for C \
+given a FlatBuffer schema file."
+HOMEPAGE = "https://github.com/dvidelabs/flatcc"
+SECTION = "devel/lib"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b3d8fb7158bf7e2600ba3191428dc4ef"
+
+PV = "0.6.2+gitr${SRCPV}"
+
+SRC_URI = " \
+ git://github.com/dvidelabs/flatcc.git;protocol=https;branch=master \
+"
+SRCREV = "1653ec964730ec7d9892a08a1695ada6d20f5196"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+# Enable installation for target
+# Disable tests as is not possible to execute with cross-compilation
+EXTRA_OECMAKE += " \
+ -DFLATCC_INSTALL=On \
+ -DFLATCC_TEST=Off \
+"
+
+BBCLASSEXTEND = "native nativesdk"