aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorRobert Joslyn <robert.joslyn@redrectangle.org>2021-05-20 22:35:49 -0700
committerKhem Raj <raj.khem@gmail.com>2021-05-21 00:23:54 -0700
commitbdb9adbeb4a3cf2d38b5922e80e092608953a9fa (patch)
treeed288212f37d7056f7052ea30fb7ec04dbb437a3 /meta-oe/recipes-devtools
parenta116630318789f08ebc6f350c37ef43f0884cb30 (diff)
downloadmeta-openembedded-contrib-bdb9adbeb4a3cf2d38b5922e80e092608953a9fa.tar.gz
ctags: Use PACKAGECONFIG for build options
Make the dependencies optional via PACKAGECONFIG where possible to make it easier for users to enable or disable them as desired. Set the new PACKAGECONFIG defaults to recreate what was built previously. The configure script does not have a manpages option, resulting in a warning: ctags-5.9.20210502.0-r0 do_configure: QA Issue: ctags: invalid PACKAGECONFIG: manpages [invalid-packageconfig] The configure script detects if rst2man.py is available, and enables creating the man pages if found. Add python3-docutils-native as a dependency only when documentation is requested. Remove commented code which looks like leftover debugging. The binary is installed as expected. Signed-off-by: Robert Joslyn <robert.joslyn@redrectangle.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/ctags/ctags_5.9.20210502.0.bb17
1 files changed, 13 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/ctags/ctags_5.9.20210502.0.bb b/meta-oe/recipes-devtools/ctags/ctags_5.9.20210502.0.bb
index aca0502db6..273d6e5730 100644
--- a/meta-oe/recipes-devtools/ctags/ctags_5.9.20210502.0.bb
+++ b/meta-oe/recipes-devtools/ctags/ctags_5.9.20210502.0.bb
@@ -14,12 +14,21 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
inherit autotools-brokensep pkgconfig manpages
-DEPENDS += "libxml2 jansson libyaml python3-docutils-native"
SRCREV = "6df08b82d4845d1b9420d9268f24d5db16ee4480"
SRC_URI = "git://github.com/universal-ctags/ctags"
S = "${WORKDIR}/git"
-#do_install() {
-# install -Dm 755 ${B}/ctags ${D}${bindir}/ctags
-#}
+PACKAGECONFIG ??= " \
+ readcmd \
+ xml \
+ json \
+ yaml \
+"
+PACKAGECONFIG[readcmd] = "--enable-readcmd,--disable-readcmd"
+PACKAGECONFIG[etags] = "--enable-etags,--disable-etags"
+PACKAGECONFIG[xml] = "--enable-xml,--disable-xml,libxml2"
+PACKAGECONFIG[json] = "--enable-json,--disable-json,jansson"
+PACKAGECONFIG[seccomp] = "--enable-seccomp,--disable-seccomp,libseccomp"
+PACKAGECONFIG[yaml] = "--enable-yaml,--disable-yaml,libyaml"
+PACKAGECONFIG[manpages] = ",,python3-docutils-native"