aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-10-26 13:54:49 -0700
committerArmin Kuster <akuster808@gmail.com>2018-03-01 16:10:36 -0800
commite2d5593aed521d4d3ae6fa66daafe1305de9dda7 (patch)
tree7a7990c03e897c882b92a3d9ee5fced82f617be1 /meta-oe/recipes-devtools
parent56121f12f124bcfa4b94074bde2742542d402cc1 (diff)
downloadmeta-openembedded-contrib-e2d5593aed521d4d3ae6fa66daafe1305de9dda7.tar.gz
pm-qa: move to recipe-test
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/pm-qa/pm-qa_git.bb65
1 files changed, 0 insertions, 65 deletions
diff --git a/meta-oe/recipes-devtools/pm-qa/pm-qa_git.bb b/meta-oe/recipes-devtools/pm-qa/pm-qa_git.bb
deleted file mode 100644
index 1ee6573bdb..0000000000
--- a/meta-oe/recipes-devtools/pm-qa/pm-qa_git.bb
+++ /dev/null
@@ -1,65 +0,0 @@
-DESCRIPTION = "Utilities for testing Power Management"
-HOMEPAGE = "https://wiki.linaro.org/WorkingGroups/PowerManagement/Resources/TestSuite/PmQa"
-
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-
-PV = "0.5.2"
-
-BRANCH ?= "master"
-
-SRCREV = "05710ec5032be4c8edafb4109d4d908d31243906"
-
-SRC_URI = "git://git.linaro.org/power/pm-qa.git;protocol=git;branch=${BRANCH}"
-
-S = "${WORKDIR}/git"
-
-CFLAGS += "-pthread"
-
-do_compile () {
- # Find all the .c files in this project and build them.
- for x in `find . -name "*.c"`
- do
- util=`echo ${x} | sed s/.c$//`
- oe_runmake ${util}
- done
-}
-
-do_install () {
- install -d ${D}${bindir}
- install -d ${D}${libdir}/${BPN}
-
- # Install the compiled binaries that were built in the previous step
- for x in `find . -name "*.c"`
- do
- util=`echo ${x} | sed s/.c$//`
- util_basename=`basename ${util}`
- install -m 0755 ${util} ${D}${bindir}/${util_basename}
- done
-
- # Install the helper scripts in a subdirectory of $libdir
- for script in `find . -name "*.sh" | grep include`
- do
- # Remove hardcoded relative paths
- sed -i -e 's#..\/utils\/##' ${script}
-
- script_basename=`basename ${script}`
- install -m 0755 $script ${D}${libdir}/${BPN}/${script_basename}
- done
-
- # Install the shell scripts NOT in the $libdir directory since those
- # will be installed elsewhere
- for script in `find . -name "*.sh" | grep -v include`
- do
- # if the script includes any helper scripts from the $libdir
- # directory then change the source path to the absolute path
- # to reflect the install location of the helper scripts.
- sed -i -e "s#source ../include#source ${libdir}/${BPN}#g" ${script}
- # Remove hardcoded relative paths
- sed -i -e 's#..\/utils\/##' ${script}
-
- script_basename=`basename ${script}`
- install -m 0755 $script ${D}${bindir}/${script_basename}
- done
-}
-RDEPENDS_${PN} +="bash"