aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2019-02-28 03:20:49 -0500
committerKhem Raj <raj.khem@gmail.com>2019-02-28 09:42:11 -0800
commite8606116247cda0991f7e653d9ff6969cf423b09 (patch)
treeeecc360f9d59f0cb16be05c690689654b46c7e19 /meta-oe/recipes-devtools
parent24d7a7790b6d4875267b054e9e69ca4afbc1587f (diff)
downloadmeta-openembedded-contrib-e8606116247cda0991f7e653d9ff6969cf423b09.tar.gz
xmlrpc-c: inherit binconfig
libreport calls xmlrpc-c-config from package xmlrpc-c-native to get cflags and libs. But it gets dirs in ${STAGING_DIR_NATIVE} which make lib32-libreport compile failed with config: require conf/multilib.conf MACHINE = "qemuarm64" MULTILIBS = "multilib:lib32" DEFAULTTUNE_virtclass-multilib-lib32 = "armv7vethf" | arm-wrs-linux-gnueabi-libtool: link: (cd ".libs" && rm -f "libabrt_dbus.so" && ln -s "libabrt_dbus.so.0.0.1" "libabrt_dbus.so") | .../tmp-glibc/work/armv5e-wrs-linux-gnueabi/libreport/2.9.7-r0/recipe-sysroot-native/usr/lib/libxml2.so: file not recognized: file format not recognized | collect2: error: ld returned 1 exit status | make[3]: *** [Makefile:780: libreport-web.la] Error 1 Make xmlrpc-c inherit binconfig to avoid such kind of errors. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.51.03.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.51.03.bb b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.51.03.bb
index 02ea8cc5fc..524263760c 100644
--- a/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.51.03.bb
+++ b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.51.03.bb
@@ -17,7 +17,7 @@ S = "${WORKDIR}/git/stable"
DEPENDS = "libxml2"
RDEPENDS_${PN} = "perl"
-inherit autotools-brokensep pkgconfig
+inherit autotools-brokensep binconfig pkgconfig
TARGET_CFLAGS += "-Wno-narrowing"