aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-08-27 07:15:10 +0800
committerKhem Raj <raj.khem@gmail.com>2019-08-27 12:11:16 -0700
commitc15a701afdacd0d8e3026710dfb7b0746b9da1f8 (patch)
treec92bdf4ebc97907d9341846021b630da925321e1 /meta-oe/recipes-devtools
parent5be68d1f9bfd76a77c29b599563531e1bc4895f4 (diff)
downloadmeta-openembedded-contrib-c15a701afdacd0d8e3026710dfb7b0746b9da1f8.tar.gz
pugixml: add recipe
pugixml is a light-weight, simple and fast XML parser for C++ with XPath support. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/pugixml/pugixml_1.9.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/pugixml/pugixml_1.9.bb b/meta-oe/recipes-devtools/pugixml/pugixml_1.9.bb
new file mode 100644
index 0000000000..ad45f87ecd
--- /dev/null
+++ b/meta-oe/recipes-devtools/pugixml/pugixml_1.9.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Light-weight C++ XML Processing Library"
+DESCRIPTION = "pugixml is a C++ XML processing library, which consists of a \
+DOM-like interface with rich traversal/modification capabilities, \
+an extremely fast XML parser which constructs the DOM tree from \
+n XML file/buffer, and an XPath 1.0 implementation for complex \
+data-driven tree queries."
+HOMPAGE = "https://pugixml.org/"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://readme.txt;beginline=29;endline=52;md5=1d569c2ed59c94ddd9586051f8c67da6"
+
+SRC_URI = "https://github.com/zeux/${BPN}/releases/download/v${PV}/${BP}.tar.gz"
+SRC_URI[md5sum] = "7286ee2ed11376b6b780ced19fae0b64"
+SRC_URI[sha256sum] = "d156d35b83f680e40fd6412c4455fdd03544339779134617b9b28d19e11fdba6"
+
+inherit cmake
+
+EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON \
+ -DCMAKE_BUILD_TYPE=Release \
+ "