aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorOlivia Yin <hong-hua.yin@freescale.com>2013-05-07 04:29:03 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-10 11:02:37 +0200
commiteb040205f38eb0e2c28ccc7b4f64e9541cc82cc0 (patch)
tree64dd6f3e3331d8b0da2944a1ea02477cde1b9f2e /meta-oe/recipes-devtools
parent1eb3e91030cee6d5765a1924b605fb689573c6ad (diff)
downloadmeta-openembedded-contrib-eb040205f38eb0e2c28ccc7b4f64e9541cc82cc0.tar.gz
yajl: pass the cmake variable LIB_SUFFIX to handle installation on 64-bit systems
WARNING: QA Issue: yajl: Files/directories were installed but not shipped /usr/lib /usr/lib/libyajl.so.2 /usr/lib/libyajl.so /usr/lib/libyajl_s.a /usr/lib/libyajl.so.2.0.4 /usr/lib/.debug /usr/lib/.debug/libyajl.so.2.0.4 NOTE: for 64-bit systems where lib64 is used you can pass the cmake variable LIB_SUFFIX to cause installation into the system's 'lib64' directory. Signed-off-by: Olivia Yin <hong-hua.yin@freescale.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/yajl/yajl_2.0.4.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/yajl/yajl_2.0.4.bb b/meta-oe/recipes-devtools/yajl/yajl_2.0.4.bb
index 735952076d..9d67e2d9fc 100644
--- a/meta-oe/recipes-devtools/yajl/yajl_2.0.4.bb
+++ b/meta-oe/recipes-devtools/yajl/yajl_2.0.4.bb
@@ -1,6 +1,7 @@
DESCRIPTION = "Yet Another JSON Library - A Portable JSON parsing and serialization library in ANSI C"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=74f541bd9a2b6c8e5d0714bcdc327f32"
+PR = "r1"
SRCREV = "fee1ebef9fa7dc0e9f5a23f37123b19b68c796ff"
SRC_URI = "git://github.com/lloyd/yajl.git"
@@ -8,3 +9,5 @@ SRC_URI = "git://github.com/lloyd/yajl.git"
S = "${WORKDIR}/git"
inherit cmake lib_package
+
+EXTRA_OECMAKE = "-DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')}"